summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-boot/cromwell-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-boot/cromwell-bin')
-rw-r--r--sys-boot/cromwell-bin/Manifest2
-rw-r--r--sys-boot/cromwell-bin/cromwell-bin-2.31.ebuild23
-rw-r--r--sys-boot/cromwell-bin/cromwell-bin-2.40.ebuild23
-rw-r--r--sys-boot/cromwell-bin/metadata.xml9
4 files changed, 57 insertions, 0 deletions
diff --git a/sys-boot/cromwell-bin/Manifest b/sys-boot/cromwell-bin/Manifest
new file mode 100644
index 000000000000..0d2858c27f0b
--- /dev/null
+++ b/sys-boot/cromwell-bin/Manifest
@@ -0,0 +1,2 @@
+DIST cromwell-2.31.tar.gz 543461 SHA256 0611fa76c3a4311e66f0d80686f27de73e1394f8d92f54a5addb09d55cebb22e
+DIST cromwell-2.40.tar.gz 541204 SHA256 b3f078f1e5069a39d3767aa8f579906d39983478d51c9ad2989c337b9148299a
diff --git a/sys-boot/cromwell-bin/cromwell-bin-2.31.ebuild b/sys-boot/cromwell-bin/cromwell-bin-2.31.ebuild
new file mode 100644
index 000000000000..c40840e2b882
--- /dev/null
+++ b/sys-boot/cromwell-bin/cromwell-bin-2.31.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit mount-boot
+
+IUSE=""
+DESCRIPTION="Xbox boot loader precompiled binaries from xbox-linux.org"
+SRC_URI="mirror://sourceforge/xbox-linux/cromwell-${PV}.tar.gz"
+HOMEPAGE="http://www.xbox-linux.org"
+RESTRICT="${RESTRICT} strip"
+DEPEND=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* x86"
+
+S=${WORKDIR}/cromwell
+
+src_install () {
+ dodir /boot/${PN}
+ insinto /boot/${PN}
+ doins ${S}/image.bin ${S}/image_1024.bin ${S}/default.xbe || die
+}
diff --git a/sys-boot/cromwell-bin/cromwell-bin-2.40.ebuild b/sys-boot/cromwell-bin/cromwell-bin-2.40.ebuild
new file mode 100644
index 000000000000..55d26c0ef78a
--- /dev/null
+++ b/sys-boot/cromwell-bin/cromwell-bin-2.40.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit mount-boot
+
+IUSE=""
+DESCRIPTION="Xbox boot loader precompiled binaries from xbox-linux.org"
+SRC_URI="mirror://sourceforge/xbox-linux/cromwell-${PV}.tar.gz"
+HOMEPAGE="http://www.xbox-linux.org"
+RESTRICT="${RESTRICT} strip"
+DEPEND=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* x86"
+
+S=${WORKDIR}/cromwell-${PV}
+
+src_install () {
+ dodir /boot/${PN}
+ insinto /boot/${PN}
+ doins ${S}/cromwell.bin ${S}/cromwell_1024.bin ${S}/xromwell.xbe || die
+}
diff --git a/sys-boot/cromwell-bin/metadata.xml b/sys-boot/cromwell-bin/metadata.xml
new file mode 100644
index 000000000000..d4df99f68ee2
--- /dev/null
+++ b/sys-boot/cromwell-bin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>xbox</herd>
+ <longdescription>Xbox boot loader (prebuilt binary)</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xbox-linux</remote-id>
+ </upstream>
+</pkgmetadata>