summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-20 11:55:43 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-20 11:56:22 +0200
commitde9ddf0d8414328da4af833bbf46c9810084852f (patch)
tree1703e08ac7d02475ac481961fe4c743e898675cf /sys-boot/palo/files/palo-2.12-gcc10.patch
parentkde-apps/dolphin: x86 stable wrt bug #719732 (diff)
downloadgentoo-de9ddf0d8414328da4af833bbf46c9810084852f.tar.gz
gentoo-de9ddf0d8414328da4af833bbf46c9810084852f.tar.bz2
gentoo-de9ddf0d8414328da4af833bbf46c9810084852f.zip
sys-boot/palo: Fix compiling ipl with GCC 10
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Bug: https://bugs.gentoo.org/724264 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-boot/palo/files/palo-2.12-gcc10.patch')
-rw-r--r--sys-boot/palo/files/palo-2.12-gcc10.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-boot/palo/files/palo-2.12-gcc10.patch b/sys-boot/palo/files/palo-2.12-gcc10.patch
new file mode 100644
index 000000000000..7832fbeac942
--- /dev/null
+++ b/sys-boot/palo/files/palo-2.12-gcc10.patch
@@ -0,0 +1,11 @@
+--- a/ipl/Makefile
++++ b/ipl/Makefile
+@@ -39,7 +39,7 @@ endif
+ VPATH=../lib:.
+
+ AFLAGS = -I../lib
+-CFLAGS = -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks
++CFLAGS = -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks -fno-builtin
+ LDFLAGS = -N --section-start .init=0x60000 -e '$$START$$'
+
+ all: iplelf