summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-02 03:12:27 +0100
committerSam James <sam@gentoo.org>2023-06-02 03:12:27 +0100
commite000110e26ea65fb310dd03aff6f0d92c7405ced (patch)
tree4e65cdbd2dea7e9a741df5377049230155544667 /sys-boot/palo
parentdev-python/jinja2_pluralize: enable py3.12 (diff)
downloadgentoo-e000110e26ea65fb310dd03aff6f0d92c7405ced.tar.gz
gentoo-e000110e26ea65fb310dd03aff6f0d92c7405ced.tar.bz2
gentoo-e000110e26ea65fb310dd03aff6f0d92c7405ced.zip
sys-boot/palo: add 2.24
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot/palo')
-rw-r--r--sys-boot/palo/Manifest1
-rw-r--r--sys-boot/palo/palo-2.24.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index 6bacac28d425..be0404c817cc 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -1 +1,2 @@
DIST palo-2.22.tar.gz 130037 BLAKE2B bbca5662ecc0d67bb8af478ee67f5d872888170b0072d6b2620b3c6ca61e52f6519209b620ffb1dfc40d1e746b522dc89118e292fd5cb78e9f3ba7eec7277a2b SHA512 817bf2dc40d01464aa943cd5495950b89196628f2ef002f6334bbc526515d9e4885532821bf18134b7d4b3adbd20d850ee2d6c2350a663f432d567ac56ef7a90
+DIST palo-2.24.tar.gz 132587 BLAKE2B a24bd6b70cf395b1254c280821f92eb00e02cb2dc0cc142e7bb706361c86a2fd45424f832d6c3ff383f02bde3eccc6e250a7ee279af3977b5bc2b2576e6ac9d0 SHA512 e520eff46798b7b94eed081c6310b1dfda07918e5f31ce140095b6742d81b85e62a657aa3761f9a3819ad7c8897d548af8fdd85b43997386c2ec6ace6fbf1b2e
diff --git a/sys-boot/palo/palo-2.24.ebuild b/sys-boot/palo/palo-2.24.ebuild
new file mode 100644
index 000000000000..6eae2c2820e0
--- /dev/null
+++ b/sys-boot/palo/palo-2.24.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="PALO: PArisc Linux Loader"
+HOMEPAGE="https://parisc.wiki.kernel.org/ https://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git"
+ inherit git-r3
+else
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="-* ~hppa"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LD="$(tc-getLD)" ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /etc/kernel/postinst.d
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+
+ doman palo.8
+
+ dodoc TODO debian/changelog README.html
+}