summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2016-11-06 11:15:42 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2016-11-06 11:23:42 -0500
commitb2a111b7db0784f57894abdea13febc300f4d235 (patch)
treef05b72d94072839cc00000be74c2ab5b2b881630 /sys-boot
parentsys-boot/refind: prevent from using user's CFLAGS for EFI compilation, bug #5... (diff)
downloadgentoo-b2a111b7db0784f57894abdea13febc300f4d235.tar.gz
gentoo-b2a111b7db0784f57894abdea13febc300f4d235.tar.bz2
gentoo-b2a111b7db0784f57894abdea13febc300f4d235.zip
sys-boot/refind: add missing EROOT in postinst
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/refind/refind-0.10.2-r2.ebuild4
-rw-r--r--sys-boot/refind/refind-0.10.3-r1.ebuild4
-rw-r--r--sys-boot/refind/refind-0.10.4-r1.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/sys-boot/refind/refind-0.10.2-r2.ebuild b/sys-boot/refind/refind-0.10.2-r2.ebuild
index 1d5029605b94..8f0fe224aa88 100644
--- a/sys-boot/refind/refind-0.10.2-r2.ebuild
+++ b/sys-boot/refind/refind-0.10.2-r2.ebuild
@@ -147,7 +147,7 @@ src_install() {
}
pkg_postinst() {
- elog "rEFInd has been built and installed into /usr/share/${P}"
+ elog "rEFInd has been built and installed into ${EROOT%/}/usr/share/${P}"
elog "You will need to use the command 'refind-install' to install"
elog "the binaries into your EFI System Partition"
if [[ -z "${REPLACING_VERSIONS}" ]]; then
@@ -158,7 +158,7 @@ pkg_postinst() {
elog " sys-block/parted for automatic ESP location and mount"
elog ""
elog "A sample configuration can be found at"
- elog "/usr/share/${P}/refind/refind.conf-sample"
+ elog "${EROOT%/}/usr/share/${P}/refind/refind.conf-sample"
else
ewarn "Note that this will not update any EFI binaries on your EFI"
ewarn "System Partition - this needs to be done manually."
diff --git a/sys-boot/refind/refind-0.10.3-r1.ebuild b/sys-boot/refind/refind-0.10.3-r1.ebuild
index fcf8d9d0ac03..a5556a3b2abb 100644
--- a/sys-boot/refind/refind-0.10.3-r1.ebuild
+++ b/sys-boot/refind/refind-0.10.3-r1.ebuild
@@ -148,7 +148,7 @@ src_install() {
}
pkg_postinst() {
- elog "rEFInd has been built and installed into /usr/share/${P}"
+ elog "rEFInd has been built and installed into ${EROOT%/}/usr/share/${P}"
elog "You will need to use the command 'refind-install' to install"
elog "the binaries into your EFI System Partition"
elog ""
@@ -161,7 +161,7 @@ pkg_postinst() {
elog "refind-mkdefault requires >=dev-lang/python-3"
elog ""
elog "A sample configuration can be found at"
- elog "/usr/share/${P}/refind/refind.conf-sample"
+ elog "${EROOT%/}/usr/share/${P}/refind/refind.conf-sample"
else
if ! version_is_at_least "0.10.3" "${REPLACING_VERSIONS}"; then
elog "The new refind-mkdefault script requires >=dev-lang/python-3"
diff --git a/sys-boot/refind/refind-0.10.4-r1.ebuild b/sys-boot/refind/refind-0.10.4-r1.ebuild
index fcf8d9d0ac03..2bc85ce09261 100644
--- a/sys-boot/refind/refind-0.10.4-r1.ebuild
+++ b/sys-boot/refind/refind-0.10.4-r1.ebuild
@@ -148,7 +148,7 @@ src_install() {
}
pkg_postinst() {
- elog "rEFInd has been built and installed into /usr/share/${P}"
+ elog "rEFInd has been built and installed into ${EROOT%/}/usr/share/${P}"
elog "You will need to use the command 'refind-install' to install"
elog "the binaries into your EFI System Partition"
elog ""
@@ -161,7 +161,7 @@ pkg_postinst() {
elog "refind-mkdefault requires >=dev-lang/python-3"
elog ""
elog "A sample configuration can be found at"
- elog "/usr/share/${P}/refind/refind.conf-sample"
+ elog "${EROOT%}/usr/share/${P}/refind/refind.conf-sample"
else
if ! version_is_at_least "0.10.3" "${REPLACING_VERSIONS}"; then
elog "The new refind-mkdefault script requires >=dev-lang/python-3"