summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBiosias <jakub@gdos.sk>2024-11-19 12:45:22 +0100
committerNowa Ammerlaan <nowa@gentoo.org>2024-11-19 13:58:20 +0100
commitc4ebeb2b4ce1dbb7e5f810568800d1c102fbc5c4 (patch)
treea0a01a54ae88acbd5a53bdfc85fee0f8158e41ce /sys-boot
parentmedia-video/mkvtoolnix: remove unused patch (diff)
downloadgentoo-c4ebeb2b4ce1dbb7e5f810568800d1c102fbc5c4.tar.gz
gentoo-c4ebeb2b4ce1dbb7e5f810568800d1c102fbc5c4.tar.bz2
gentoo-c4ebeb2b4ce1dbb7e5f810568800d1c102fbc5c4.zip
sys-boot/uefi-mkconfig: add 3.3
Signed-off-by: Biosias <jakub@gdos.sk> Closes: https://github.com/gentoo/gentoo/pull/39370 Signed-off-by: Nowa Ammerlaan <nowa@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/uefi-mkconfig/Manifest1
-rw-r--r--sys-boot/uefi-mkconfig/uefi-mkconfig-3.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-boot/uefi-mkconfig/Manifest b/sys-boot/uefi-mkconfig/Manifest
index f3d148388533..54d39b038769 100644
--- a/sys-boot/uefi-mkconfig/Manifest
+++ b/sys-boot/uefi-mkconfig/Manifest
@@ -1,2 +1,3 @@
DIST uefi-mkconfig-2.3.tar.gz 10295 BLAKE2B cae2301b1c181f87efbb47fbb393184ed383d763932999719223a298062cd802c318aeb9a1e4571483fe872b31ee27c86186a1200531d038e4ffe867ac683361 SHA512 730546552739db386249e0f86bce029ccb2695bd4b065326ae91ae92ab350ee387e46b661514b80728e609aa851a78efdda97a86fd7418c6f0044341c393c452
DIST uefi-mkconfig-3.2.tar.gz 13817 BLAKE2B 2d9d1d37c83e2e0a8b9e833745fee96303aba57d546cb63bd4b6b4447409a19dc48bc7183fcf22ba0cc809e5a68bdbc8fc3989cdbf1c2076a8ea025a21005e0b SHA512 fe9a412d49826151fd1f1363a7961f9339afb8ac869d600063a5ca1595b8a1e53917b3649b3bc3a5f85b0e5a23c9f16ab6e13b453430bbd35ceaa1b478d6eeb6
+DIST uefi-mkconfig-3.3.tar.gz 14444 BLAKE2B 028562cf41ad4e936a60fad695ab9342f9c06f67e8ccb5afaaf72ad1d5cde3938e8b344d64c375b9468c61fb7074645c5f9ab6c8f351ed93215ae0b7d8d96143 SHA512 5a8236edffef7a3de8d463dcca1006bf54f3e86538d3fd797e49ec545056bab4d974b7e64fe9a37110c1cc671d4261197074cbcb35be0744e02a3742ebb8e398
diff --git a/sys-boot/uefi-mkconfig/uefi-mkconfig-3.3.ebuild b/sys-boot/uefi-mkconfig/uefi-mkconfig-3.3.ebuild
new file mode 100644
index 000000000000..eb46eef391d5
--- /dev/null
+++ b/sys-boot/uefi-mkconfig/uefi-mkconfig-3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info optfeature
+
+DESCRIPTION="Automatic management of UEFI entries"
+HOMEPAGE="https://github.com/Biosias/uefi-mkconfig"
+SRC_URI="https://github.com/Biosias/uefi-mkconfig/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ app-shells/bash
+ sys-boot/efibootmgr
+"
+
+CONFIG_CHECK="~EFI_STUB"
+
+src_install() {
+ dobin uefi-mkconfig
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "uefi-mkconfig: Automatic management of UEFI entries"
+ elog "Run uefi-mkconfig while having all efi partitions mounted"
+ elog "Please use with care, this package was tested on a limited number of machines"
+ elog "Some problems may arise due to different implementations of UEFI"
+ elog "Don't forget to add kernel commands to the configuration file before using this package!"
+ elog
+ optfeature "Add UEFI entries on kernel installation " \ "sys-kernel/installkernel[-systemd,efistub]"
+}