summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-06-19 18:03:49 +0200
committerStephan Hartmann <sultan@gentoo.org>2022-06-19 18:03:49 +0200
commit71c068be98a510b39a8fda11bfaecaa36fe8f7d3 (patch)
tree641acc52bcb40668b2ac25ee66f869486e871b15 /sys-cluster
parentsys-cluster/ploop: fix install path (diff)
downloadgentoo-71c068be98a510b39a8fda11bfaecaa36fe8f7d3.tar.gz
gentoo-71c068be98a510b39a8fda11bfaecaa36fe8f7d3.tar.bz2
gentoo-71c068be98a510b39a8fda11bfaecaa36fe8f7d3.zip
sys-cluster/ploop: add 1.15
Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ploop/Manifest1
-rw-r--r--sys-cluster/ploop/files/ploop-1.15-makedev-include.patch12
-rw-r--r--sys-cluster/ploop/ploop-1.15.ebuild64
3 files changed, 77 insertions, 0 deletions
diff --git a/sys-cluster/ploop/Manifest b/sys-cluster/ploop/Manifest
index dee8217c2c4e..adfb985c05c0 100644
--- a/sys-cluster/ploop/Manifest
+++ b/sys-cluster/ploop/Manifest
@@ -1 +1,2 @@
DIST ploop-1.14.1.tar.bz2 123962 BLAKE2B d4f4f102d2ec0714d79901bd3193f85514e232dc18ffcab254becb954cf794f3598fe7b0f65d0bbb85766bff5ded9d816900b40b81cb6046c31d8b6459c67618 SHA512 7a235865f071de6e2762923d6591c8c6ee00d0d05ec80c6a2a1332f5b6881ccf827f7ddc40dfe1d663b8abf492a188a23f7d28a43dd553d6e37c8091cb3bc484
+DIST ploop-1.15.tar.bz2 125618 BLAKE2B ad7d06865606c20bdd9601ce343817a332653f3f7544dd27f08d3fb5ff2ee8112ef1ae0217546c28fde3dba076b0703b5881e8a019eec663964dd39885c5524c SHA512 07a691aeed949971534dcf9bb5138defacf25d7c437336df84a5ec3759cba0c20f6724660b7c8a204b3f455d15a892e20b060b0e0ea27280eeba738c36f280cb
diff --git a/sys-cluster/ploop/files/ploop-1.15-makedev-include.patch b/sys-cluster/ploop/files/ploop-1.15-makedev-include.patch
new file mode 100644
index 000000000000..81ebf2ac9ea4
--- /dev/null
+++ b/sys-cluster/ploop/files/ploop-1.15-makedev-include.patch
@@ -0,0 +1,12 @@
+diff --git a/lib/delta_sysfs.c b/lib/delta_sysfs.c
+index 98e7254..e44fb3b 100644
+--- a/lib/delta_sysfs.c
++++ b/lib/delta_sysfs.c
+@@ -29,6 +29,7 @@
+ #include <linux/fs.h>
+ #include <sys/ioctl.h>
+ #include <sys/utsname.h>
++#include <sys/sysmacros.h>
+
+ #include "ploop.h"
+
diff --git a/sys-cluster/ploop/ploop-1.15.ebuild b/sys-cluster/ploop/ploop-1.15.ebuild
new file mode 100644
index 000000000000..c554d97126d1
--- /dev/null
+++ b/sys-cluster/ploop/ploop-1.15.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit tmpfiles toolchain-funcs
+
+DESCRIPTION="openvz tool and a library to control ploop block devices"
+HOMEPAGE="https://wiki.openvz.org/Download/ploop"
+SRC_URI="https://download.openvz.org/utils/ploop/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/libxml2"
+RDEPEND="${DEPEND}
+ sys-block/parted
+ sys-fs/e2fsprogs
+ sys-process/lsof
+ sys-apps/findutils"
+
+PATCHES=(
+ "${FILESDIR}"/disable_create_run_dir.patch
+ "${FILESDIR}"/${PN}-1.15-makedev-include.patch
+)
+
+DOCS=( tools/README )
+
+src_prepare() {
+ default
+
+ # Respect CFLAGS and CC, do not add debug by default
+ sed -i \
+ -e 's|CFLAGS =|CFLAGS +=|' \
+ -e '/CFLAGS/s/-g -O0 //' \
+ -e '/CFLAGS/s/-O2//' \
+ -e 's|CC=|CC?=|' \
+ -e 's/-Werror//' \
+ -e '/DEBUG=yes/d' \
+ -e '/LOCKDIR/s/var/run/' \
+ Makefile.inc || die 'sed on Makefile.inc failed'
+ # Avoid striping of binaries
+ sed -e '/INSTALL/{s: -s::}' -i tools/Makefile || die 'sed on tools/Makefile failed'
+
+ # respect AR and RANLIB, bug #452092
+ tc-export AR RANLIB
+ sed -i -e 's/ranlib/$(RANLIB)/' lib/Makefile || die 'sed on lib/Makefile failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 $(usex debug 'DEBUG' '' '=yes' '')
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR=/usr/$(get_libdir) install
+ rm "${ED}"/usr/$(get_libdir)/*.a || die
+}
+
+pkg_postinst() {
+ tmpfiles_process ploop.conf
+}