summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-25 12:41:32 +0100
committerSam James <sam@gentoo.org>2022-10-25 12:42:25 +0100
commitbec6a7be57fc3493dccef497b5d4b513c315f5f1 (patch)
tree9cbdd9ffd02c4bcc3f9bfa8cf76639be0f2cae0f /sys-devel/flex/files
parentmedia-libs/flac: Stabilize 1.4.2 arm64, #878251 (diff)
downloadgentoo-bec6a7be57fc3493dccef497b5d4b513c315f5f1.tar.gz
gentoo-bec6a7be57fc3493dccef497b5d4b513c315f5f1.tar.bz2
gentoo-bec6a7be57fc3493dccef497b5d4b513c315f5f1.zip
sys-devel/flex: backport "config.h" fix too
We already have the patch to config.h/configure.ac backported but we don't have the fix to actually *use* config.h everywhere, and clearly from bug #705800 it wasn't sufficient to just backport it (for reasons covered in the bug & upstream bug). Bug: https://bugs.gentoo.org/628744 Bug: https://bugs.gentoo.org/705800 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/flex/files')
-rw-r--r--sys-devel/flex/files/flex-2.6.4-implicit-func-decl.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-devel/flex/files/flex-2.6.4-implicit-func-decl.patch b/sys-devel/flex/files/flex-2.6.4-implicit-func-decl.patch
new file mode 100644
index 000000000000..1900ae0529b9
--- /dev/null
+++ b/sys-devel/flex/files/flex-2.6.4-implicit-func-decl.patch
@@ -0,0 +1,50 @@
+https://github.com/westes/flex/commit/4b5111d9772b5c160340ca96f08d30d7f6db5cda
+https://github.com/westes/flex/issues/436
+https://bugs.gentoo.org/705800
+https://developers.redhat.com/blog/2019/04/22/implicit-function-declarations-flexs-use-of-reallocarray
+
+From 4b5111d9772b5c160340ca96f08d30d7f6db5cda Mon Sep 17 00:00:00 2001
+From: Explorer09 <explorer09@gmail.com>
+Date: Mon, 4 Sep 2017 08:28:53 +0800
+Subject: [PATCH] scanner: Include flexdef.h at %top block of scan.l
+
+config.h may define macros that alter the API of the standard library
+funtions, and so it should be included before any other standard
+header, even before the skeleton's standard header inclusion.
+
+For example: config.h may #define _GNU_SOURCE that would expose the
+reallocarray() prototype from <stdlib.h> on glibc 2.26+ systems. If we
+include <stdlib.h> before config.h, reallocarray() would not be
+available for use in lex file since the second include doesn't help
+due to header guard.
+
+For now our config.h might `#define malloc rpl_malloc` -- this
+substitution must work before including stdlib.h, or else the compiler
+will complain about missing prototypes, and may result in incorrect
+code in scan.l (gcc warning: return makes pointer from integer without
+a cast [-Wint-conversion]).
+
+Fixes #247.
+--- a/src/scan.l
++++ b/src/scan.l
+@@ -1,5 +1,11 @@
+ /* scan.l - scanner for flex input -*-C-*- */
+
++%top{
++/* flexdef.h includes config.h, which may contain macros that alter the API */
++/* of libc functions. Must include first before any libc header. */
++#include "flexdef.h"
++}
++
+ %{
+ /* Copyright (c) 1990 The Regents of the University of California. */
+ /* All rights reserved. */
+@@ -32,7 +38,6 @@
+ /* WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR */
+ /* PURPOSE. */
+
+-#include "flexdef.h"
+ #include "parse.h"
+ extern bool tablesverify, tablesext;
+ extern int trlcontxt; /* Set in parse.y for each rule. */
+