summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leogrande <dark.knight.ita@gmail.com>2015-12-08 21:42:29 -0800
committerMarco Leogrande <dark.knight.ita@gmail.com>2015-12-12 13:46:24 -0800
commitbd92864b47dc6b6d3352eb5c82ce7c0dcc1c8d30 (patch)
treeda6908c37bbf5b6c3c77fc41e42b86156decc116 /sys-devel/llvm
parentgames-emulation/dolphin: Adds updates to 9999 ebuild, bug #561914 (diff)
downloadgentoo-bd92864b47dc6b6d3352eb5c82ce7c0dcc1c8d30.tar.gz
gentoo-bd92864b47dc6b6d3352eb5c82ce7c0dcc1c8d30.tar.bz2
gentoo-bd92864b47dc6b6d3352eb5c82ce7c0dcc1c8d30.zip
sys-devel/llvm: add BPF backend to compiled targets
As part of 3.7.* releases, LLVM has officially added support for the BPF backend. This backend emits instructions in the eBPF language, that is used in the homonymous Linux kernel virtual machine. Users of LLVM can write a program in C and have it compiled directly into eBPF. This commit adds support for compiling this backend unconditionally.
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 2f8afe756340..d36085c8690b 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -215,7 +215,7 @@ multilib_src_configure() {
if use multitarget; then
targets=all
else
- targets='host;CppBackend'
+ targets='host;BPF;CppBackend'
use video_cards_radeon && targets+=';AMDGPU'
fi