summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Ilinykh <rion4ik@gmail.com>2020-03-14 14:51:41 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-16 22:28:27 +0100
commit1185f5d80edbdb2cda8f32c62225c178e8304478 (patch)
treefe24cc395d46b659aebec7b955dd9fc4d78125c5 /sys-devel/qconf/qconf-2.5.ebuild
parentnet-im/psi: sync with upstream (diff)
downloadgentoo-1185f5d80edbdb2cda8f32c62225c178e8304478.tar.gz
gentoo-1185f5d80edbdb2cda8f32c62225c178e8304478.tar.bz2
gentoo-1185f5d80edbdb2cda8f32c62225c178e8304478.zip
sys-devel/qconf: bumped to 2.5
Signed-off-by: Sergey Ilinykh <rion4ik@gmail.com> Closes: https://bugs.gentoo.org/682428 Closes: https://github.com/gentoo/gentoo/pull/14951 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-devel/qconf/qconf-2.5.ebuild')
-rw-r--r--sys-devel/qconf/qconf-2.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/qconf/qconf-2.5.ebuild b/sys-devel/qconf/qconf-2.5.ebuild
new file mode 100644
index 000000000000..0064bce46584
--- /dev/null
+++ b/sys-devel/qconf/qconf-2.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="./configure like generator for qmake-based projects"
+HOMEPAGE="https://github.com/psi-im/qconf"
+SRC_URI="https://github.com/psi-im/qconf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtxml:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # not autotools configure, so don't use econf
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --qtdir="$(qt5_get_libdir)/qt5" \
+ --extraconf=QMAKE_STRIP= \
+ --verbose || die "configure failed"
+
+ # just to set all the Gentoo toolchain flags
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+ dodoc -r examples
+}