summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-16 19:40:28 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-16 22:52:08 +0100
commit36760bd16adda87265f594b93d0eccb91b7b7f79 (patch)
tree2afce36416f993f423d28d9c5a3835114f8a719d /sys-devel
parentdev-ml/llvm-ocaml: Stop enforcing external lit for tests (diff)
downloadgentoo-36760bd16adda87265f594b93d0eccb91b7b7f79.tar.gz
gentoo-36760bd16adda87265f594b93d0eccb91b7b7f79.tar.bz2
gentoo-36760bd16adda87265f594b93d0eccb91b7b7f79.zip
sys-devel/clang: Stop enforcing external lit for tests (in <9999)
Modify the ebuild to no longer enforce externally installed dev-python/lit for tests, effectively causing the build system to use the bundled copy of lit (along with llvm-lit). While using the external package is more canonical, its disadvantages outweight the gain. Most notably, lit is not slotted in Gentoo and the behavior of lit frequently changes subtly which caused us to require a major version match between LLVM and lit. As a result, attempting to build multiple slots of LLVM with tests enabled cause package collisions. Building both LLVM and lit simultaneously causes a circular dependency. Since lit comes from the same package as LLVM and clang requires it anyway for gtest, using the bundled copy has no added cost. However, the live ebuild is currently broken as it requires llvm-lit that is not created in the stand-alone build. This will be fixed upstream.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/clang-4.0.1.ebuild2
-rw-r--r--sys-devel/clang/clang-5.0.9999.ebuild2
-rw-r--r--sys-devel/clang/clang-9999.ebuild2
3 files changed, 0 insertions, 6 deletions
diff --git a/sys-devel/clang/clang-4.0.1.ebuild b/sys-devel/clang/clang-4.0.1.ebuild
index 1c7814d237e0..03fb42db1de0 100644
--- a/sys-devel/clang/clang-4.0.1.ebuild
+++ b/sys-devel/clang/clang-4.0.1.ebuild
@@ -38,7 +38,6 @@ RDEPEND="
# configparser-3.2 breaks the build (3.3 or none at all are fine)
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )
- test? ( ~dev-python/lit-${PV}[${PYTHON_USEDEP}] )
xml? ( virtual/pkgconfig )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
@@ -142,7 +141,6 @@ multilib_src_configure() {
)
use test && mycmakeargs+=(
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
)
if multilib_is_native_abi; then
diff --git a/sys-devel/clang/clang-5.0.9999.ebuild b/sys-devel/clang/clang-5.0.9999.ebuild
index b8bfe4b8916a..46db8c8117a9 100644
--- a/sys-devel/clang/clang-5.0.9999.ebuild
+++ b/sys-devel/clang/clang-5.0.9999.ebuild
@@ -41,7 +41,6 @@ RDEPEND="
# configparser-3.2 breaks the build (3.3 or none at all are fine)
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )
- test? ( ~dev-python/lit-${PV}[${PYTHON_USEDEP}] )
xml? ( virtual/pkgconfig )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
@@ -141,7 +140,6 @@ multilib_src_configure() {
)
use test && mycmakeargs+=(
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
)
if multilib_is_native_abi; then
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 178c15c76134..c52113796199 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -42,7 +42,6 @@ RDEPEND="
# configparser-3.2 breaks the build (3.3 or none at all are fine)
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )
- test? ( ~dev-python/lit-${PV}[${PYTHON_USEDEP}] )
xml? ( virtual/pkgconfig )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
@@ -137,7 +136,6 @@ multilib_src_configure() {
)
use test && mycmakeargs+=(
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv"
)