summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKostadin Shishmanov <kocelfc@tutanota.com>2024-11-19 22:49:09 +0200
committerMichał Górny <mgorny@gentoo.org>2024-11-20 08:55:46 +0100
commit7181aa049ad1850028e970e702f9532608f9ea91 (patch)
treebed21297933b0099bb0fb3ae2068f88723537c25 /sys-devel
parentdev-ruby/dnsruby: drop 1.70.0, 1.71.0 (diff)
downloadgentoo-7181aa049ad1850028e970e702f9532608f9ea91.tar.gz
gentoo-7181aa049ad1850028e970e702f9532608f9ea91.tar.bz2
gentoo-7181aa049ad1850028e970e702f9532608f9ea91.zip
sys-devel/lld: allow LTO
The ODR warnings have been fixed upstream [1] [2], so we can now allow building with LTO for 18.x and newer. Builds without errors and the test suite passes with both GCC and Clang. [1] https://github.com/llvm/llvm-project/issues/83529 [2] https://github.com/llvm/llvm-project/pull/83604 Bug: https://bugs.gentoo.org/922353 Signed-off-by: Kostadin Shishmanov <kocelfc@tutanota.com> Closes: https://github.com/gentoo/gentoo/pull/39377 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/lld/lld-18.1.8.ebuild3
-rw-r--r--sys-devel/lld/lld-19.1.4.ebuild3
-rw-r--r--sys-devel/lld/lld-20.0.0.9999.ebuild3
3 files changed, 0 insertions, 9 deletions
diff --git a/sys-devel/lld/lld-18.1.8.ebuild b/sys-devel/lld/lld-18.1.8.ebuild
index d5245986a556..64b6082241c4 100644
--- a/sys-devel/lld/lld-18.1.8.ebuild
+++ b/sys-devel/lld/lld-18.1.8.ebuild
@@ -59,9 +59,6 @@ src_unpack() {
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
- # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
- filter-lto
-
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/sys-devel/lld/lld-19.1.4.ebuild b/sys-devel/lld/lld-19.1.4.ebuild
index f8e23cb7e5b3..8aa86d3f073c 100644
--- a/sys-devel/lld/lld-19.1.4.ebuild
+++ b/sys-devel/lld/lld-19.1.4.ebuild
@@ -59,9 +59,6 @@ src_unpack() {
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
- # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
- filter-lto
-
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/sys-devel/lld/lld-20.0.0.9999.ebuild b/sys-devel/lld/lld-20.0.0.9999.ebuild
index 79558afa1abe..07358f891cd0 100644
--- a/sys-devel/lld/lld-20.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-20.0.0.9999.ebuild
@@ -58,9 +58,6 @@ src_unpack() {
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
- # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
- filter-lto
-
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"