summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-20 11:40:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-20 13:22:33 +0200
commitbb14e2d334bf0e7e6034a3197339ab22d80080cd (patch)
tree25536fe645062ace7a5da1a39bee907b2373b207 /sys-devel
parentsys-libs/libomp: Bump to 10.0.1_rc1 (diff)
downloadgentoo-bb14e2d334bf0e7e6034a3197339ab22d80080cd.tar.gz
gentoo-bb14e2d334bf0e7e6034a3197339ab22d80080cd.tar.bz2
gentoo-bb14e2d334bf0e7e6034a3197339ab22d80080cd.zip
sys-devel/clang-runtime: Bump to 10.0.1_rc1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-10.0.1_rc1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-10.0.1_rc1.ebuild b/sys-devel/clang-runtime/clang-runtime-10.0.1_rc1.ebuild
new file mode 100644
index 000000000000..65e66879ab98
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-10.0.1_rc1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"