summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-05 21:48:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-05 21:50:02 +0200
commitd3d8343eba3cf47e921ba75f878f90644753da6e (patch)
tree59753104f8e291e8bf2a5e73e61f50f6b1d6c488 /sys-devel
parentsys-libs/libomp: Add 16.* live ebuilds (diff)
downloadgentoo-d3d8343eba3cf47e921ba75f878f90644753da6e.tar.gz
gentoo-d3d8343eba3cf47e921ba75f878f90644753da6e.tar.bz2
gentoo-d3d8343eba3cf47e921ba75f878f90644753da6e.zip
sys-devel/clang-runtime: Add 16.* live ebuilds
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-16.0.0.9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-16.0.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-16.0.0.9999.ebuild
new file mode 100644
index 000000000000..e4ff9326ddcb
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-16.0.0.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"