summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-02-07 00:17:37 +0000
committerSam James <sam@gentoo.org>2024-02-11 13:35:35 +0000
commitdd927e4ede05c4b468fa778b8ddf83ae7e8ce297 (patch)
treebfa20671d2582d89be654e0f765d0848f326ba3e /sys-devel
parentnet-dns/rbldnsd: define USE=ipv6 locally to avoid a pkgcheck warning (diff)
downloadgentoo-dd927e4ede05c4b468fa778b8ddf83ae7e8ce297.tar.gz
gentoo-dd927e4ede05c4b468fa778b8ddf83ae7e8ce297.tar.bz2
gentoo-dd927e4ede05c4b468fa778b8ddf83ae7e8ce297.zip
sys-devel/clang-common: fixes for darwin
Add keywords, remove unsupported linker option Bug: https://bugs.gentoo.org/758167 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-16.0.6-r2.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.6-r1.ebuild19
-rw-r--r--sys-devel/clang-common/clang-common-18.1.0_rc2.ebuild17
-rw-r--r--sys-devel/clang-common/clang-common-19.0.0.9999.ebuild17
-rw-r--r--sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild17
-rw-r--r--sys-devel/clang-common/clang-common-19.0.0_pre20240210.ebuild17
6 files changed, 62 insertions, 27 deletions
diff --git a/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild b/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild
index 4385b576d482..a118a00dae9b 100644
--- a/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos"
IUSE="
default-compiler-rt default-libcxx default-lld
bootstrap-prefix hardened llvm-libunwind
diff --git a/sys-devel/clang-common/clang-common-17.0.6-r1.ebuild b/sys-devel/clang-common/clang-common-17.0.6-r1.ebuild
index 0083e09889b4..d680a956dfe1 100644
--- a/sys-devel/clang-common/clang-common-17.0.6-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.6-r1.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos"
IUSE="
default-compiler-rt default-libcxx default-lld
bootstrap-prefix hardened llvm-libunwind
@@ -175,11 +175,18 @@ src_install() {
-include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
- newins - gentoo-hardened-ld.cfg <<-EOF
- # Some of these options are added unconditionally, regardless of
- # USE=hardened, for parity with sys-devel/gcc.
- -Wl,-z,relro
- EOF
+ if use kernel_Darwin; then
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # There was -Wl,-z,relro here, but it's not supported on Mac
+ # TODO: investigate whether -bind_at_load or -read_only_stubs will do the job
+ EOF
+ else
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # Some of these options are added unconditionally, regardless of
+ # USE=hardened, for parity with sys-devel/gcc.
+ -Wl,-z,relro
+ EOF
+ fi
dodir /usr/include/gentoo
diff --git a/sys-devel/clang-common/clang-common-18.1.0_rc2.ebuild b/sys-devel/clang-common/clang-common-18.1.0_rc2.ebuild
index a50679150043..80d989986d28 100644
--- a/sys-devel/clang-common/clang-common-18.1.0_rc2.ebuild
+++ b/sys-devel/clang-common/clang-common-18.1.0_rc2.ebuild
@@ -174,11 +174,18 @@ src_install() {
-include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
- newins - gentoo-hardened-ld.cfg <<-EOF
- # Some of these options are added unconditionally, regardless of
- # USE=hardened, for parity with sys-devel/gcc.
- -Wl,-z,relro
- EOF
+ if use kernel_Darwin; then
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # There was -Wl,-z,relro here, but it's not supported on Mac
+ # TODO: investigate whether -bind_at_load or -read_only_stubs will do the job
+ EOF
+ else
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # Some of these options are added unconditionally, regardless of
+ # USE=hardened, for parity with sys-devel/gcc.
+ -Wl,-z,relro
+ EOF
+ fi
dodir /usr/include/gentoo
diff --git a/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild
index a50679150043..80d989986d28 100644
--- a/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild
@@ -174,11 +174,18 @@ src_install() {
-include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
- newins - gentoo-hardened-ld.cfg <<-EOF
- # Some of these options are added unconditionally, regardless of
- # USE=hardened, for parity with sys-devel/gcc.
- -Wl,-z,relro
- EOF
+ if use kernel_Darwin; then
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # There was -Wl,-z,relro here, but it's not supported on Mac
+ # TODO: investigate whether -bind_at_load or -read_only_stubs will do the job
+ EOF
+ else
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # Some of these options are added unconditionally, regardless of
+ # USE=hardened, for parity with sys-devel/gcc.
+ -Wl,-z,relro
+ EOF
+ fi
dodir /usr/include/gentoo
diff --git a/sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild b/sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild
index a50679150043..80d989986d28 100644
--- a/sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild
+++ b/sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild
@@ -174,11 +174,18 @@ src_install() {
-include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
- newins - gentoo-hardened-ld.cfg <<-EOF
- # Some of these options are added unconditionally, regardless of
- # USE=hardened, for parity with sys-devel/gcc.
- -Wl,-z,relro
- EOF
+ if use kernel_Darwin; then
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # There was -Wl,-z,relro here, but it's not supported on Mac
+ # TODO: investigate whether -bind_at_load or -read_only_stubs will do the job
+ EOF
+ else
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # Some of these options are added unconditionally, regardless of
+ # USE=hardened, for parity with sys-devel/gcc.
+ -Wl,-z,relro
+ EOF
+ fi
dodir /usr/include/gentoo
diff --git a/sys-devel/clang-common/clang-common-19.0.0_pre20240210.ebuild b/sys-devel/clang-common/clang-common-19.0.0_pre20240210.ebuild
index a50679150043..80d989986d28 100644
--- a/sys-devel/clang-common/clang-common-19.0.0_pre20240210.ebuild
+++ b/sys-devel/clang-common/clang-common-19.0.0_pre20240210.ebuild
@@ -174,11 +174,18 @@ src_install() {
-include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
- newins - gentoo-hardened-ld.cfg <<-EOF
- # Some of these options are added unconditionally, regardless of
- # USE=hardened, for parity with sys-devel/gcc.
- -Wl,-z,relro
- EOF
+ if use kernel_Darwin; then
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # There was -Wl,-z,relro here, but it's not supported on Mac
+ # TODO: investigate whether -bind_at_load or -read_only_stubs will do the job
+ EOF
+ else
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # Some of these options are added unconditionally, regardless of
+ # USE=hardened, for parity with sys-devel/gcc.
+ -Wl,-z,relro
+ EOF
+ fi
dodir /usr/include/gentoo