summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-11-24 11:57:45 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-11-24 12:00:14 +0300
commit390b20810a61c3a1019325f4bb6abcf495fa768e (patch)
treebb1c7bade4be3ebe3c8f9618c4399e30bdf0a210 /sys-fs/rarfs/rarfs-0.1.1-r1.ebuild
parentapp-doc/casting-spels-emacs: Bump to EAPI 6. Update HOMEPAGE. (diff)
downloadgentoo-390b20810a61c3a1019325f4bb6abcf495fa768e.tar.gz
gentoo-390b20810a61c3a1019325f4bb6abcf495fa768e.tar.bz2
gentoo-390b20810a61c3a1019325f4bb6abcf495fa768e.zip
sys-fs/rarfs: revision bump
EAPI 6, port to python-r1 eclass. Drop old revision Gentoo-Bug: 599828 Package-Manager: portage-2.3.2
Diffstat (limited to 'sys-fs/rarfs/rarfs-0.1.1-r1.ebuild')
-rw-r--r--sys-fs/rarfs/rarfs-0.1.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/rarfs/rarfs-0.1.1-r1.ebuild b/sys-fs/rarfs/rarfs-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..79d0d7c2e984
--- /dev/null
+++ b/sys-fs/rarfs/rarfs-0.1.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-r1
+
+DESCRIPTION="Fuse module to mount uncompressed RAR archives"
+HOMEPAGE="https://sourceforge.net/projects/rarfs/"
+SRC_URI="mirror://sourceforge/rarfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-fs/fuse"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README )
+
+src_install() {
+ dobin scripts/prarfs
+ python_replicate_script "${ED}/usr/bin/prarfs"
+
+ dobin src/rarfs
+ einstalldocs
+}