summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-16 22:14:51 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-16 22:17:42 -0400
commit0194567625da237b25ff55bdc95190592a690962 (patch)
tree3ba06024dc049720265a2412ef0e7c49d852ee4f /sys-fs
parentgames-fps/qudos: update HOMEPAGE and SRC_URI (diff)
downloadgentoo-0194567625da237b25ff55bdc95190592a690962.tar.gz
gentoo-0194567625da237b25ff55bdc95190592a690962.tar.bz2
gentoo-0194567625da237b25ff55bdc95190592a690962.zip
sys-fs/mtd-utils: fix building w/newer glibc #580206
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mtd-utils/files/mtd-utils-1.5.2-sysmacros.patch32
-rw-r--r--sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild4
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-fs/mtd-utils/files/mtd-utils-1.5.2-sysmacros.patch b/sys-fs/mtd-utils/files/mtd-utils-1.5.2-sysmacros.patch
new file mode 100644
index 000000000000..5fc055d07da9
--- /dev/null
+++ b/sys-fs/mtd-utils/files/mtd-utils-1.5.2-sysmacros.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/580206
+
+From 9a06f45ec71116d76ee4b268ebe1b33d45b06fc0 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 16 Apr 2016 22:10:43 -0400
+Subject: [PATCH mtd-utils] include sys/sysmacros.h for major/minor/makedev
+
+These functions have always been defined in sys/sysmacros.h under
+Linux C libraries. For some, including sys/types.h implicitly
+includes that as well, but glibc wants to deprecate that, and some
+others already have. Include the header explicitly for the funcs.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/common.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/common.h b/include/common.h
+index fb0ca83..8cb3142 100644
+--- a/include/common.h
++++ b/include/common.h
+@@ -28,6 +28,7 @@
+ #include <errno.h>
+ #include <features.h>
+ #include <inttypes.h>
++#include <sys/sysmacros.h>
+ #include "version.h"
+
+ #ifndef PROGRAM_NAME
+--
+2.7.4
+
diff --git a/sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild b/sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild
index 26c0a62d42d7..176261d254e4 100644
--- a/sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild
+++ b/sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild
@@ -40,6 +40,10 @@ RDEPEND="!sys-fs/mtd
DEPEND="${RDEPEND}
xattr? ( sys-apps/acl )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sysmacros.patch #580206
+}
+
makeopts() {
# These affect build output, so keep it common between compile & install.
echo CROSS=${CHOST}- V=1