summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-09-04 12:58:04 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-09-04 13:06:05 +0200
commit7dec9ac33a53cdda750f64a1dd79789c0076d418 (patch)
treef29fd92bb509dd344c9f9507f42b2b04b56a1968 /sys-fs
parentgui-wm/gamescope: Bump to 3.11.43, drop old 3.11.42 (diff)
downloadgentoo-7dec9ac33a53cdda750f64a1dd79789c0076d418.tar.gz
gentoo-7dec9ac33a53cdda750f64a1dd79789c0076d418.tar.bz2
gentoo-7dec9ac33a53cdda750f64a1dd79789c0076d418.zip
sys-fs/cryptmount: add 6.0
Bug: https://bugs.gentoo.org/864340 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptmount/Manifest1
-rw-r--r--sys-fs/cryptmount/cryptmount-6.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/sys-fs/cryptmount/Manifest b/sys-fs/cryptmount/Manifest
index a59d3072e054..7b61f5f27489 100644
--- a/sys-fs/cryptmount/Manifest
+++ b/sys-fs/cryptmount/Manifest
@@ -1 +1,2 @@
DIST cryptmount-5.3.3.tar.gz 545925 BLAKE2B 7a20d3a3b5805b1fe9ed84aafe6aaebeab4c62652dc8f53ecd70a7e0a0aa993ab5a03d54967910b94e6d8bde28f7ee7bb90a115a2bf101c9d4f4177fee26f90d SHA512 9945630316feee513a64e11dffa61ece77d0dff43a7b611d91fcb0a7c902402effb30ba15266d52c2f5381aa3ab7290a9a0999ca391c3c15cbdb83debe7dcca0
+DIST cryptmount-6.0.tar.gz 556919 BLAKE2B 54226756a6772810ff68c78ff38502df3890a428830eaa34612640d7e5cefd92085e288c5e45ff5b7e5c8bb8b524f458e55f5080e7e62435ae33a46f76c06845 SHA512 aac4ea4969542ade267b3c697988b15ded23fca3c7a330c7b78d990b2b3ad1a393af2d0bea93908187b50e404847cd580a325182397e2667064165764a55b017
diff --git a/sys-fs/cryptmount/cryptmount-6.0.ebuild b/sys-fs/cryptmount/cryptmount-6.0.ebuild
new file mode 100644
index 000000000000..e7fbfa348097
--- /dev/null
+++ b/sys-fs/cryptmount/cryptmount-6.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="A utility for management and user-mode mounting of encrypted filesystems"
+HOMEPAGE="http://cryptmount.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="argv0switch cswap fsck +gcrypt +largefile mount +nls +luks +openssl selinux systemd udev"
+REQUIRED_USE="
+ luks? ( gcrypt )
+ openssl? ( gcrypt )
+"
+
+RDEPEND="
+ sys-fs/lvm2
+ virtual/libiconv
+ virtual/libintl
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ luks? ( sys-fs/cryptsetup )
+ openssl? ( dev-libs/openssl:0= )
+ systemd? ( sys-apps/systemd )
+ udev? ( virtual/udev )
+"
+
+DEPEND="
+ ${RDEPEND}
+ sys-kernel/linux-headers
+"
+
+BDEPEND="nls? ( sys-devel/gettext )"
+
+DOCS=( "AUTHORS" "ChangeLog" "NEWS" "README" "README.sshfs" "RELNOTES" "ToDo" )
+
+CONFIG_CHECK="BLK_DEV_DM"
+ERROR_BLK_DEV_DM="
+ Please enable Device Mapper support in your kernel config
+ -> Device Drivers
+ -> Multiple devices driver support (RAID and LVM)
+ -> Multiple devices driver support (RAID and LVM)
+ <*>/<M> Device mapper support
+"
+
+src_prepare() {
+ default
+
+ # Since SELinux is hardcoded, remove it on disabled SELinux profile
+ if ! use selinux; then
+ sed -e '/selinux/d' -i dmutils.c || die
+ fi
+}
+
+src_configure() {
+ local myeconf=(
+ --disable-rpath
+ $(use_enable argv0switch)
+ $(use_enable cswap)
+ $(use_enable fsck)
+ $(use_with gcrypt libgcrypt)
+ $(use_enable largefile)
+ $(use_enable mount delegation)
+ $(use_enable nls)
+ $(use_enable luks)
+ $(use_enable openssl openssl-compat)
+ $(use_with systemd)
+ $(use_enable udev libudev)
+
+ )
+
+ econf "${myeconf[@]}"
+}