summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-08-20 18:16:04 -0400
committerMike Pagano <mpagano@gentoo.org>2023-08-20 18:16:04 -0400
commit464fe55338ffabd9ad0d6ff4d09c8f0c4fa411f7 (patch)
treecdb8c0a5c8cf5c286652e8658f2457090e2a59f8 /sys-kernel/git-sources
parentgui-wm/gamescope: Bump to 3.12.3, drop old 3.11.51 + 3.12.0 (diff)
downloadgentoo-464fe55338ffabd9ad0d6ff4d09c8f0c4fa411f7.tar.gz
gentoo-464fe55338ffabd9ad0d6ff4d09c8f0c4fa411f7.tar.bz2
gentoo-464fe55338ffabd9ad0d6ff4d09c8f0c4fa411f7.zip
sys-kernel/git-sources: add 6.5_rc7
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.5_rc7.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index b2c08dbd5e20..953b3b2a3c80 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-6.5-rc3.patch 79471277 BLAKE2B 7f66470c266dcfef345a9b8909c68060beb87b
DIST patch-6.5-rc4.patch 79882880 BLAKE2B c272c129d17704203bf139b9ece1eec27b823d0e5c75d2fd111c0e5df54c2c8dcc79aad78a9bb823d63b88246794fd19327be33751b85cd7839d6b6d66038c39 SHA512 d4e96c1968332a268720d2bcdb679c2f9ff540887a1b4cec43011c80cae4453c7105ecce494b143dcccb0f78d7d918c13d2e909b0ef007bdcb8242c0c3e43980
DIST patch-6.5-rc5.patch 80131790 BLAKE2B aa1e5e9ce5269207d0d5ab3d27967cfe8960821c3bd67be0b58cc5aff32a866325f35090a0ec30a18b6c21aba52435ae07b3e182734398550e2481d538bcf590 SHA512 65472fe82f2b0498b1aa916b246638781667efd6e3ba4518baaeafc7c4b1dd919802cf0351832080065ae099e9814691a6075d718258e53d61311198c60d9296
DIST patch-6.5-rc6.patch 80504775 BLAKE2B b4ce0b26847e708517260d5f5c57c48059715cf37e984ad88727feb392f192a976f0bb2be899511784896881e9530cb5bd66e9b4dc19ca4e5a80150dd7a104ea SHA512 b9a225ede39b6f1bb8dcfb1ba1313a378842c906d3aa1956d2a0f856cfe40ab688d9a15c5fba050e6745e42e2ea18b09092844382ebbf2f5aab6320e338d02d6
+DIST patch-6.5-rc7.patch 80687935 BLAKE2B 530cc662c2568ecd656ec409ff571824a3ee5bebe0fb04840eb8b0c1c346f18a4d2b66310bb9c50da9b313a25d03d7fa51a82d90ef32d8390d53e44b781a2c84 SHA512 185214fb8de78a89bab22e03c60375ae1df7a76b242d99f240816b0b318bb3a79e288f02888a27bec166306f2eac5df6bf22e1318fc8485e34a7ce7c9996e345
diff --git a/sys-kernel/git-sources/git-sources-6.5_rc7.ebuild b/sys-kernel/git-sources/git-sources-6.5_rc7.ebuild
new file mode 100644
index 000000000000..ddb3116ab32a
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.5_rc7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.4"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}