summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-21 08:19:16 +0000
committerSam James <sam@gentoo.org>2021-11-21 08:19:25 +0000
commite38d58fb426a48d75b67d5df41e557c3657339cd (patch)
tree05b9d57cee4e457080ab5516f551164ed07afdca /sys-kernel/raspberrypi-image/raspberrypi-image-5.10.63_p20211029.ebuild
parentdev-python/cheetah-docs: treeclean (diff)
downloadgentoo-e38d58fb426a48d75b67d5df41e557c3657339cd.tar.gz
gentoo-e38d58fb426a48d75b67d5df41e557c3657339cd.tar.bz2
gentoo-e38d58fb426a48d75b67d5df41e557c3657339cd.zip
sys-kernel/raspberrypi-image: add 5.10.63_p20211029
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-kernel/raspberrypi-image/raspberrypi-image-5.10.63_p20211029.ebuild')
-rw-r--r--sys-kernel/raspberrypi-image/raspberrypi-image-5.10.63_p20211029.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-image/raspberrypi-image-5.10.63_p20211029.ebuild b/sys-kernel/raspberrypi-image/raspberrypi-image-5.10.63_p20211029.ebuild
new file mode 100644
index 000000000000..c889903dd8ca
--- /dev/null
+++ b/sys-kernel/raspberrypi-image/raspberrypi-image-5.10.63_p20211029.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mount-boot
+
+# Go to e.g. https://github.com/raspberrypi/firmware/tree/1.20211029/modules
+# for the latest tag to see which kernel version it corresponds to.
+
+DESCRIPTION="Raspberry Pi (all versions) kernel and modules"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+RESTRICT="binchecks strip"
+
+# Temporary safety measure to prevent ending up with a pair of
+# sys-kernel/raspberrypi-image and sys-boot/raspberrypi-firmware
+# both of which installed device tree files.
+# Restore to simply "sys-boot/raspberrypi-firmware" when the mentioned version
+# and all older ones are deleted.
+RDEPEND=">sys-boot/raspberrypi-firmware-1.20190709"
+
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
+ EGIT_CLONE_TYPE="shallow"
+else
+ [[ "$(ver_cut 4)" == 'p' ]] || die "Unsupported version format, tweak the ebuild."
+ MY_PV="1.$(ver_cut 5)"
+ SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV}.tar.gz -> raspberrypi-firmware-${MY_PV}.tar.gz"
+ S="${WORKDIR}/firmware-${MY_PV}"
+ KEYWORDS="-* ~arm ~arm64"
+fi
+
+src_install() {
+ insinto /lib/modules
+ doins -r modules/*
+ insinto /boot
+ doins boot/*.img
+
+ doins boot/*.dtb
+ doins -r boot/overlays
+}