summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-30 20:26:12 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-30 22:23:57 +0200
commit0e342e881c7e0bb9da496f685d23a2ae143c5353 (patch)
tree5da6c477f8080ee8529217c21114404e7e401c27 /sys-kernel
parentnet-vpn/openfortivpn: add 1.20.3 (diff)
downloadgentoo-0e342e881c7e0bb9da496f685d23a2ae143c5353.tar.gz
gentoo-0e342e881c7e0bb9da496f685d23a2ae143c5353.tar.bz2
gentoo-0e342e881c7e0bb9da496f685d23a2ae143c5353.zip
sys-kernel/vanilla-kernel: Bump to 6.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/vanilla-kernel/Manifest2
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-6.3.5.ebuild137
2 files changed, 139 insertions, 0 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index fbd20a5fc9fc..dd747d7b2407 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -57,3 +57,5 @@ DIST linux-6.2.16.tar.sign 989 BLAKE2B 1e61250c6fb0c9d2e2419a16748b85cb804ef039f
DIST linux-6.2.16.tar.xz 136509012 BLAKE2B 3357159d25bdd7ac95db7830e22be35e7f8b746673474b3050baea73e90e52e42a4723e6c19242fcb26e579bf52040ab726317fd74a85c37f722653e60ea4e61 SHA512 7f98d8ee2417272e2ab1517f6b7150f74033622e24a9426fc924c75aea46ab22b8ec8c73fc2523378fdb80f8899a3c6a55036a20dd30e438c1d6d39ea036f2c3
DIST linux-6.3.4.tar.sign 987 BLAKE2B b61e9860c2fdd710bfec1b71a4d6bf96fd905ab52d40c3d9e0f0237297488d48b1ddbcc6c59cd048aebf4ea3f3fe701d5ad44309be82ae99136c66fd1f2b54b6 SHA512 d21eb8559aaa66e8dc78f2e5bb9434eae89a208d50af9f945de4979195a0aac4ee0c0018867a2d6ed5ed1d3e14830e750b7a3c87d3eccb3c40e5b10fb7a0cbf9
DIST linux-6.3.4.tar.xz 136914364 BLAKE2B 7e287378e007ce83092c2630d87d5e2b77e1615386a275013f04a190c6cab129e5ddc3abf8213ae521c8722d41cb8d203bb5cc5ae84d9bcd20aebbbc2db1d8a3 SHA512 f9d07b728e66c5da3ef0deec9432e2ca1e56d1fb5d98d2e1cb7cf23744fbf837f41fe918de7842410eab0d89ecf213f0b76db925e4c5bfb265e263eeea24436d
+DIST linux-6.3.5.tar.sign 987 BLAKE2B 34ed1d758eb42af9d27b6aec986c9f52426b19ad9a7483d1b4eb1b4873e7e10efd9c102fa7e17d1fba5df15ba536ab77e6597b607dd07ea9012860fe9eff2c34 SHA512 a701dea5d297c217eb2b497a9441399c0f386f39f74f726f81872f8144d83973ec02ce533b7d48cb9c49d38a98c820668d684927983a001f7a8a27067f605867
+DIST linux-6.3.5.tar.xz 136926988 BLAKE2B 646a94591eae93db9301a11e5300579c8cce7d2a544727cb88efed86d05ba070a247498d9c83d7b7cdbead4e7d46537134c877813aa7f188dd36b403c58d0c11 SHA512 91a98c56191645c4ba32f657da59b6be92021b37a698eaf79e1ed3a79b959626386e7b69c8cb0c9eab0645c287a3e53393b1710158eca67b2f66a8d3eaec13de
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-6.3.5.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-6.3.5.ebuild
new file mode 100644
index 000000000000..98a956be057f
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-6.3.5.ebuild
@@ -0,0 +1,137 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit kernel-build toolchain-funcs verify-sig
+
+MY_P=linux-${PV}
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+# forked to https://github.com/projg2/fedora-kernel-config-for-gentoo
+CONFIG_VER=6.3.1-gentoo
+GENTOO_CONFIG_VER=g7
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="
+ https://wiki.gentoo.org/wiki/Project:Distribution_Kernel
+ https://www.kernel.org/
+"
+SRC_URI+="
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ https://github.com/projg2/gentoo-kernel-config/archive/${GENTOO_CONFIG_VER}.tar.gz
+ -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
+ verify-sig? (
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.sign
+ )
+ amd64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-x86_64-fedora.config
+ -> kernel-x86_64-fedora.config.${CONFIG_VER}
+ )
+ arm64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-aarch64-fedora.config
+ -> kernel-aarch64-fedora.config.${CONFIG_VER}
+ )
+ ppc64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-ppc64le-fedora.config
+ -> kernel-ppc64le-fedora.config.${CONFIG_VER}
+ )
+ x86? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-i686-fedora.config
+ -> kernel-i686-fedora.config.${CONFIG_VER}
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug hardened"
+REQUIRED_USE="arm? ( savedconfig )"
+
+BDEPEND="
+ debug? ( dev-util/pahole )
+ verify-sig? ( sec-keys/openpgp-keys-kernel )
+"
+PDEPEND="
+ >=virtual/dist-kernel-${PV}
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/kernel.org.asc
+
+src_unpack() {
+ if use verify-sig; then
+ einfo "Unpacking linux-${PV}.tar.xz ..."
+ verify-sig_verify_detached - "${DISTDIR}"/linux-${PV}.tar.sign \
+ < <(xz -cd "${DISTDIR}"/linux-${PV}.tar.xz | tee >(tar -x))
+ assert "Unpack failed"
+ unpack "gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz"
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ local biendian=false
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ arm)
+ return
+ ;;
+ arm64)
+ cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ hppa)
+ return
+ ;;
+ ppc)
+ # assume powermac/powerbook defconfig
+ # we still package.use.force savedconfig
+ cp "${WORKDIR}/${MY_P}/arch/powerpc/configs/pmac32_defconfig" .config || die
+ ;;
+ ppc64)
+ cp "${DISTDIR}/kernel-ppc64le-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local myversion="-dist"
+ use hardened && myversion+="-hardened"
+ echo "CONFIG_LOCALVERSION=\"${myversion}\"" > "${T}"/version.config || die
+ local dist_conf_path="${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"
+
+ local merge_configs=(
+ "${T}"/version.config
+ "${dist_conf_path}"/base.config
+ )
+ use debug || merge_configs+=(
+ "${dist_conf_path}"/no-debug.config
+ )
+ if use hardened; then
+ merge_configs+=( "${dist_conf_path}"/hardened-base.config )
+
+ tc-is-gcc && merge_configs+=( "${dist_conf_path}"/hardened-gcc-plugins.config )
+
+ if [[ -f "${dist_conf_path}/hardened-${ARCH}.config" ]]; then
+ merge_configs+=( "${dist_conf_path}/hardened-${ARCH}.config" )
+ fi
+ fi
+
+ # this covers ppc64 and aarch64_be only for now
+ if [[ ${biendian} == true && $(tc-endian) == big ]]; then
+ merge_configs+=( "${dist_conf_path}/big-endian.config" )
+ fi
+
+ kernel-build_merge_configs "${merge_configs[@]}"
+}