summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2019-08-25 21:26:27 +0800
committerBenda Xu <heroxbd@gentoo.org>2019-08-25 21:26:58 +0800
commit19ab6715d42b41ddcb51a3395016e090f03943e9 (patch)
treebb36a3b251e2c624ca7ccbf0083600676c8f11ec /sys-libs/glibc/glibc-2.19-r2.ebuild
parentdev-qt/qtimageformats: Drop 5.12.4 (r0) (diff)
downloadgentoo-19ab6715d42b41ddcb51a3395016e090f03943e9.tar.gz
gentoo-19ab6715d42b41ddcb51a3395016e090f03943e9.tar.bz2
gentoo-19ab6715d42b41ddcb51a3395016e090f03943e9.zip
sys-libs/glibc: add kernel 2.6.16 compatibility patch.
This is only for Prefix on deprecated systems. On thoses systems, vulnerable kernels are usually used. Hardened no longer makes sense, remove. Remove versionator, as it is not used. Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-2.19-r2.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.19-r2.ebuild40
1 files changed, 4 insertions, 36 deletions
diff --git a/sys-libs/glibc/glibc-2.19-r2.ebuild b/sys-libs/glibc/glibc-2.19-r2.ebuild
index 58038d81dd61..a0b75a595e97 100644
--- a/sys-libs/glibc/glibc-2.19-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.19-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit prefix eutils versionator toolchain-funcs flag-o-matic gnuconfig usr-ldscript \
+inherit prefix eutils toolchain-funcs flag-o-matic gnuconfig usr-ldscript \
multilib systemd multiprocessing
DESCRIPTION="GNU libc C library"
@@ -32,7 +32,7 @@ PATCH_VER=9
SRC_URI+=" https://dev.gentoo.org/~dilfridge/distfiles/${P}-patches-${PATCH_VER}.tar.bz2"
SRC_URI+=" multilib? ( https://dev.gentoo.org/~dilfridge/distfiles/gcc-${GCC_BOOTSTRAP_VER}-multilib-bootstrap.tar.bz2 )"
-IUSE="audit caps compile-locales debug doc gd hardened headers-only multilib nscd profile selinux suid systemtap vanilla"
+IUSE="audit caps compile-locales debug doc gd headers-only multilib nscd profile selinux suid systemtap vanilla"
# Minimum kernel version that glibc requires
# hppa requires 2.6.20
@@ -368,21 +368,6 @@ setup_flags() {
filter-flags '-fstack-protector*'
append-flags '-fno-stack-protector'
-
- # Starting with gcc-6 (and fully upstreamed pie patches) we control
- # default enabled/disabled pie via use flags. So nothing to do
- # here then. #618160
- if [[ $(gcc-major-version) -lt 6 ]]; then
- if use hardened && tc-enables-pie ; then
- # Force PIC macro definition for all compilations since they're all
- # either -fPIC or -fPIE with the default-PIE compiler.
- append-cppflags -DPIC
- else
- # Don't build -fPIE without the default-PIE compiler and the
- # hardened-pie patch
- filter-flags -fPIE
- fi
- fi
}
want_tls() {
@@ -757,6 +742,8 @@ src_prepare() {
gnuconfig_update
+ eapply "${FILESDIR}"/2.19/glibc-2.19-kernel-2.6.16-compat.patch
+
cd "${WORKDIR}"
find . -name configure -exec touch {} +
@@ -764,25 +751,6 @@ src_prepare() {
# Fix permissions on some of the scripts.
chmod u+x "${S}"/scripts/*.sh
-
- cd "${S}"
-
- if use hardened ; then
- # We don't enable these for non-hardened as the output is very terse --
- # it only states that a crash happened. The default upstream behavior
- # includes backtraces and symbols.
- einfo "Installing Hardened Gentoo SSP and FORTIFY_SOURCE handler"
- cp "${FILESDIR}"/2.20/glibc-2.20-gentoo-stack_chk_fail.c debug/stack_chk_fail.c || die
- cp "${FILESDIR}"/2.25/glibc-2.25-gentoo-chk_fail.c debug/chk_fail.c || die
-
- if use debug ; then
- # Allow SIGABRT to dump core on non-hardened systems, or when debug is requested.
- sed -i \
- -e '/^CFLAGS-backtrace.c/ iCPPFLAGS-stack_chk_fail.c = -DSSP_SMASH_DUMPS_CORE' \
- -e '/^CFLAGS-backtrace.c/ iCPPFLAGS-chk_fail.c = -DSSP_SMASH_DUMPS_CORE' \
- debug/Makefile || die
- fi
- fi
}
glibc_do_configure() {