summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-10-12 20:49:16 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-12 21:03:05 +0100
commita56243ab61dd2088eaa21a45cbdb574505a28f6c (patch)
tree5486889e28ee88e18d6d16aee9a245807781e2b8 /sys-libs/glibc/glibc-2.19-r2.ebuild
parenttoolchain-glibc.eclass: allow glibc dongrade on I_ALLOW_TO_BREAK_MY_SYSTEM (diff)
downloadgentoo-a56243ab61dd2088eaa21a45cbdb574505a28f6c.tar.gz
gentoo-a56243ab61dd2088eaa21a45cbdb574505a28f6c.tar.bz2
gentoo-a56243ab61dd2088eaa21a45cbdb574505a28f6c.zip
sys-libs/glibc: allow glibc dongrade on I_ALLOW_TO_BREAK_MY_SYSTEM
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-2.19-r2.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.19-r2.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.19-r2.ebuild b/sys-libs/glibc/glibc-2.19-r2.ebuild
index 75f849f69dc2..0fedbb8e9409 100644
--- a/sys-libs/glibc/glibc-2.19-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.19-r2.ebuild
@@ -539,7 +539,7 @@ sanity_prechecks() {
if has_version ">${CATEGORY}/${P}-r10000" ; then
eerror "Sanity check to keep you from breaking your system:"
eerror " Downgrading glibc is not supported and a sure way to destruction."
- die "Aborting to save your system."
+ [[ ${I_ALLOW_TO_BREAK_MY_SYSTEM} = yes ]] || die "Aborting to save your system."
fi
if ! do_run_test '#include <unistd.h>\n#include <sys/syscall.h>\nint main(){return syscall(1000)!=-1;}\n' ; then