summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-07-09 01:32:07 +0100
committerMarek Szuba <marecki@gentoo.org>2023-07-09 01:32:33 +0100
commit0bc862265ed250c228bc730b7cc49a367b5fd60c (patch)
tree1385408d6b6dcf2f7165810d28599e3e43c69484 /sys-libs/libblockdev
parentsys-libs/libblockdev: add a subslot to all ebuilds (diff)
downloadgentoo-0bc862265ed250c228bc730b7cc49a367b5fd60c.tar.gz
gentoo-0bc862265ed250c228bc730b7cc49a367b5fd60c.tar.bz2
gentoo-0bc862265ed250c228bc730b7cc49a367b5fd60c.zip
sys-libs/libblockdev: sync up the live ebuild
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-libs/libblockdev')
-rw-r--r--sys-libs/libblockdev/libblockdev-9999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/sys-libs/libblockdev/libblockdev-9999.ebuild b/sys-libs/libblockdev/libblockdev-9999.ebuild
index 7d85d1383f49..c44cfbc5a2a4 100644
--- a/sys-libs/libblockdev/libblockdev-9999.ebuild
+++ b/sys-libs/libblockdev/libblockdev-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit autotools python-single-r1 xdg-utils
DESCRIPTION="A library for manipulating block devices"
@@ -21,7 +21,7 @@ else
fi
LICENSE="LGPL-2+"
SLOT="0/3" # subslot is SOVERSION
-IUSE="bcache +cryptsetup device-mapper dmraid escrow gtk-doc introspection lvm kbd +nvme test +tools"
+IUSE="+cryptsetup device-mapper escrow gtk-doc introspection lvm +nvme test +tools"
# Tests require root. In a future release, we may be able to run a smaller
# subset with new run_tests.py arguments.
RESTRICT="!test? ( test ) test"
@@ -29,6 +29,7 @@ RESTRICT="!test? ( test ) test"
RDEPEND="
>=dev-libs/glib-2.42.2
dev-libs/libbytesize
+ sys-apps/gptfdisk
>=sys-apps/kmod-19
>=sys-apps/util-linux-2.27
>=sys-block/parted-3.1
@@ -37,13 +38,9 @@ RDEPEND="
>=dev-libs/nss-3.18.0
dev-libs/volume_key
)
- >=sys-fs/cryptsetup-1.6.7:=
+ >=sys-fs/cryptsetup-2.3.0:=
)
device-mapper? ( sys-fs/lvm2 )
- dmraid? (
- sys-fs/dmraid
- sys-fs/lvm2
- )
lvm? (
sys-fs/lvm2
virtual/udev
@@ -60,6 +57,12 @@ BDEPEND+="
dev-util/gtk-doc-am
gtk-doc? ( dev-util/gtk-doc )
introspection? ( >=dev-libs/gobject-introspection-1.3.0 )
+ test? (
+ $(python_gen_cond_dep '
+ dev-libs/libbytesize[python,${PYTHON_USEDEP}]
+ ')
+ sys-block/targetcli-fb
+ )
"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -90,13 +93,10 @@ src_configure() {
--without-nvdimm
$(use_enable introspection)
$(use_enable test tests)
- $(use_with bcache)
$(use_with cryptsetup crypto)
$(use_with device-mapper dm)
- $(use_with dmraid)
$(use_with escrow)
$(use_with gtk-doc)
- $(use_with kbd)
$(use_with lvm lvm)
$(use_with lvm lvm-dbus)
$(use_with nvme)