summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-09-07 17:07:06 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2015-09-07 17:08:46 +0200
commit8364a7f7e72f15a19b19d6e1d5f7d00e2a2748df (patch)
treea81149c18eeb64db1c411d09ce22a4e2a7b5a2b1 /sys-libs/libomp/files
parentsys-apps/util-linux: Removed old. (diff)
downloadgentoo-8364a7f7e72f15a19b19d6e1d5f7d00e2a2748df.tar.gz
gentoo-8364a7f7e72f15a19b19d6e1d5f7d00e2a2748df.tar.bz2
gentoo-8364a7f7e72f15a19b19d6e1d5f7d00e2a2748df.zip
sys-libs/libomp: initial import
Thanks Jeremi Piotrowski <jeremi.piotrowski@gmail.com> in bug #559582 for the research and initial ebuild Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-libs/libomp/files')
-rw-r--r--sys-libs/libomp/files/libomp-3.7.0-no_compat_symlinks.patch17
-rw-r--r--sys-libs/libomp/files/libomp-3.7.0-os_detection.patch19
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-libs/libomp/files/libomp-3.7.0-no_compat_symlinks.patch b/sys-libs/libomp/files/libomp-3.7.0-no_compat_symlinks.patch
new file mode 100644
index 000000000000..c8b56e2bc89d
--- /dev/null
+++ b/sys-libs/libomp/files/libomp-3.7.0-no_compat_symlinks.patch
@@ -0,0 +1,17 @@
+diff -Naur openmp-3.7.0.src.orig/runtime/src/CMakeLists.txt openmp-3.7.0.src/runtime/src/CMakeLists.txt
+--- openmp-3.7.0.src.orig/runtime/src/CMakeLists.txt 2015-07-15 23:41:36.000000000 +0200
++++ openmp-3.7.0.src/runtime/src/CMakeLists.txt 2015-09-05 23:41:17.105242541 +0200
+@@ -288,13 +288,6 @@
+ endforeach()
+ else()
+ install(TARGETS omp LIBRARY DESTINATION lib${LIBOMP_LIBDIR_SUFFIX})
+- # Create aliases (symlinks) of the library for backwards compatibility
+- set(LIBOMP_ALIASES "libgomp;libiomp5")
+- foreach(alias IN LISTS LIBOMP_ALIASES)
+- install(CODE "execute_process(COMMAND \"\${CMAKE_COMMAND}\" -E create_symlink \"${LIBOMP_LIB_FILE}\"
+- \"${alias}${CMAKE_SHARED_LIBRARY_SUFFIX}\" WORKING_DIRECTORY
+- \$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/lib${LIBOMP_LIBDIR_SUFFIX})")
+- endforeach()
+ endif()
+ install(
+ FILES
diff --git a/sys-libs/libomp/files/libomp-3.7.0-os_detection.patch b/sys-libs/libomp/files/libomp-3.7.0-os_detection.patch
new file mode 100644
index 000000000000..a0b2aad375f1
--- /dev/null
+++ b/sys-libs/libomp/files/libomp-3.7.0-os_detection.patch
@@ -0,0 +1,19 @@
+diff -Naur openmp-3.7.0.src.orig/runtime/tools/lib/Uname.pm openmp-3.7.0.src/runtime/tools/lib/Uname.pm
+--- openmp-3.7.0.src.orig/runtime/tools/lib/Uname.pm 2015-01-19 19:29:35.000000000 +0100
++++ openmp-3.7.0.src/runtime/tools/lib/Uname.pm 2015-09-04 19:30:25.821746740 +0200
+@@ -236,15 +236,6 @@
+ $bulk =~ m{^DISTRIB_ID\s*=\s*(.*?)\s*$}m
+ or runtime_error( "$release: There is no DISTRIB_ID:", $bulk, "(eof)" );
+ $values{ operating_system_name } = $1;
+- $bulk =~ m{^DISTRIB_RELEASE\s*=\s*(.*?)\s*$}m
+- or runtime_error( "$release: There is no DISTRIB_RELEASE:", $bulk, "(eof)" );
+- $values{ operating_system_release } = $1;
+- $bulk =~ m{^DISTRIB_CODENAME\s*=\s*(.*?)\s*$}m
+- or runtime_error( "$release: There is no DISTRIB_CODENAME:", $bulk, "(eof)" );
+- $values{ operating_system_codename } = $1;
+- $bulk =~ m{^DISTRIB_DESCRIPTION\s*="?\s*(.*?)"?\s*$}m
+- or runtime_error( "$release: There is no DISTRIB_DESCRIPTION:", $bulk, "(eof)" );
+- $values{ operating_system_description } = $1;
+ } else {
+ # Oops. lsb-release is missed or not informative. Try other *-release files.
+ $release = "/etc/system-release";