summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-21 09:37:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-21 10:23:19 +0200
commit10830dec4992d8980c9c6018ad6f51be6dc2120b (patch)
treedb37b8d61bd1c8e2fd9a462f581cb297f01c53c8 /sys-libs
parentsci-physics/root: version bump to 6.26.06 (diff)
downloadgentoo-10830dec4992d8980c9c6018ad6f51be6dc2120b.tar.gz
gentoo-10830dec4992d8980c9c6018ad6f51be6dc2120b.tar.bz2
gentoo-10830dec4992d8980c9c6018ad6f51be6dc2120b.zip
sys-libs/libcxxabi: Force matchling LLVM/Clang version
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxxabi/libcxxabi-15.0.1.9999.ebuild13
-rw-r--r--sys-libs/libcxxabi/libcxxabi-15.0.1.ebuild13
-rw-r--r--sys-libs/libcxxabi/libcxxabi-16.0.0.9999.ebuild13
-rw-r--r--sys-libs/libcxxabi/libcxxabi-16.0.0_pre20220918.ebuild13
4 files changed, 16 insertions, 36 deletions
diff --git a/sys-libs/libcxxabi/libcxxabi-15.0.1.9999.ebuild b/sys-libs/libcxxabi/libcxxabi-15.0.1.9999.ebuild
index 893a76363592..78be4b5b862f 100644
--- a/sys-libs/libcxxabi/libcxxabi-15.0.1.9999.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-15.0.1.9999.ebuild
@@ -21,14 +21,14 @@ RESTRICT="!test? ( test )"
RDEPEND+="
!<sys-libs/libcxx-15
"
-# llvm-6 for new lit options
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
${RDEPEND}
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -57,9 +57,7 @@ pkg_setup() {
}
multilib_src_configure() {
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags
@@ -102,9 +100,6 @@ multilib_src_configure() {
-DLIBCXX_INCLUDE_TESTS=OFF
)
if use test; then
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
-
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags)"
diff --git a/sys-libs/libcxxabi/libcxxabi-15.0.1.ebuild b/sys-libs/libcxxabi/libcxxabi-15.0.1.ebuild
index 2bfe48a125b3..5665bc0cb12f 100644
--- a/sys-libs/libcxxabi/libcxxabi-15.0.1.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-15.0.1.ebuild
@@ -21,14 +21,14 @@ RESTRICT="!test? ( test )"
RDEPEND+="
!<sys-libs/libcxx-15
"
-# llvm-6 for new lit options
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
${RDEPEND}
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -57,9 +57,7 @@ pkg_setup() {
}
multilib_src_configure() {
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags
@@ -102,9 +100,6 @@ multilib_src_configure() {
-DLIBCXX_INCLUDE_TESTS=OFF
)
if use test; then
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
-
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags)"
diff --git a/sys-libs/libcxxabi/libcxxabi-16.0.0.9999.ebuild b/sys-libs/libcxxabi/libcxxabi-16.0.0.9999.ebuild
index 893a76363592..78be4b5b862f 100644
--- a/sys-libs/libcxxabi/libcxxabi-16.0.0.9999.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-16.0.0.9999.ebuild
@@ -21,14 +21,14 @@ RESTRICT="!test? ( test )"
RDEPEND+="
!<sys-libs/libcxx-15
"
-# llvm-6 for new lit options
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
${RDEPEND}
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -57,9 +57,7 @@ pkg_setup() {
}
multilib_src_configure() {
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags
@@ -102,9 +100,6 @@ multilib_src_configure() {
-DLIBCXX_INCLUDE_TESTS=OFF
)
if use test; then
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
-
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags)"
diff --git a/sys-libs/libcxxabi/libcxxabi-16.0.0_pre20220918.ebuild b/sys-libs/libcxxabi/libcxxabi-16.0.0_pre20220918.ebuild
index 893a76363592..78be4b5b862f 100644
--- a/sys-libs/libcxxabi/libcxxabi-16.0.0_pre20220918.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-16.0.0_pre20220918.ebuild
@@ -21,14 +21,14 @@ RESTRICT="!test? ( test )"
RDEPEND+="
!<sys-libs/libcxx-15
"
-# llvm-6 for new lit options
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
${RDEPEND}
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -57,9 +57,7 @@ pkg_setup() {
}
multilib_src_configure() {
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags
@@ -102,9 +100,6 @@ multilib_src_configure() {
-DLIBCXX_INCLUDE_TESTS=OFF
)
if use test; then
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
-
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags)"