summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-04 14:24:29 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-04 14:25:53 +0100
commit1b8078187d4d85e5f5a88f80b665051939dd48a3 (patch)
tree0fe80f2284d0a738cb2c4e33365f671087db34c0 /sys-libs
parentsys-libs/compiler-rt: Inline ABI_X86 flags to fix non-x86 arches (diff)
downloadgentoo-1b8078187d4d85e5f5a88f80b665051939dd48a3.tar.gz
gentoo-1b8078187d4d85e5f5a88f80b665051939dd48a3.tar.bz2
gentoo-1b8078187d4d85e5f5a88f80b665051939dd48a3.zip
sys-libs/compiler-rt-sanitizers: Inline ABI_X86 flags to fix non-x86
Inline ABI_X86 flags instead of using multilib-build, as the latter injects a REQUIRED_USE constraint that is impossible to satisfy on non-x86 architectures. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.1.9999.ebuild8
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.1_rc1.ebuild8
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-14.0.0.9999.ebuild8
3 files changed, 9 insertions, 15 deletions
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.1.9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.1.9999.ebuild
index 14e8ad24e742..166db1d476f2 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.1.9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.1.9999.ebuild
@@ -3,10 +3,8 @@
EAPI=7
-MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{8..10} )
-inherit check-reqs cmake flag-o-matic llvm llvm.org multilib-build \
- python-any-r1
+inherit check-reqs cmake flag-o-matic llvm llvm.org python-any-r1
DESCRIPTION="Compiler runtime libraries for clang (sanitizers & xray)"
HOMEPAGE="https://llvm.org/"
@@ -14,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
KEYWORDS=""
-IUSE="+clang debug test elibc_glibc"
+IUSE="+abi_x86_32 abi_x86_64 +clang debug test elibc_glibc"
# base targets
IUSE+=" +libfuzzer +memprof +orc +profile +xray"
# sanitizer targets, keep in sync with config-ix.cmake
@@ -36,7 +34,7 @@ CLANG_SLOT=${SLOT%%.*}
# llvm-6 for new lit options
DEPEND="
>=sys-devel/llvm-6
- virtual/libcrypt[${MULTILIB_USEDEP}]"
+ virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]"
BDEPEND="
>=dev-util/cmake-3.16
clang? ( sys-devel/clang )
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.1_rc1.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.1_rc1.ebuild
index 9c861d2942be..584e656370cc 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.1_rc1.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.1_rc1.ebuild
@@ -3,10 +3,8 @@
EAPI=7
-MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{8..10} )
-inherit check-reqs cmake flag-o-matic llvm llvm.org multilib-build \
- python-any-r1
+inherit check-reqs cmake flag-o-matic llvm llvm.org python-any-r1
DESCRIPTION="Compiler runtime libraries for clang (sanitizers & xray)"
HOMEPAGE="https://llvm.org/"
@@ -14,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
KEYWORDS=""
-IUSE="+clang debug test elibc_glibc"
+IUSE="+abi_x86_32 abi_x86_64 +clang debug test elibc_glibc"
# base targets
IUSE+=" +libfuzzer +memprof +orc +profile +xray"
# sanitizer targets, keep in sync with config-ix.cmake
@@ -36,7 +34,7 @@ CLANG_SLOT=${SLOT%%.*}
# llvm-6 for new lit options
DEPEND="
>=sys-devel/llvm-6
- virtual/libcrypt[${MULTILIB_USEDEP}]"
+ virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]"
BDEPEND="
>=dev-util/cmake-3.16
clang? ( sys-devel/clang )
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-14.0.0.9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-14.0.0.9999.ebuild
index bfbb1896914d..300f5b58df57 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-14.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-14.0.0.9999.ebuild
@@ -3,10 +3,8 @@
EAPI=7
-MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{8..10} )
-inherit check-reqs cmake flag-o-matic llvm llvm.org multilib-build \
- python-any-r1
+inherit check-reqs cmake flag-o-matic llvm llvm.org python-any-r1
DESCRIPTION="Compiler runtime libraries for clang (sanitizers & xray)"
HOMEPAGE="https://llvm.org/"
@@ -14,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
KEYWORDS=""
-IUSE="+clang debug test elibc_glibc"
+IUSE="+abi_x86_32 abi_x86_64 +clang debug test elibc_glibc"
# base targets
IUSE+=" +libfuzzer +memprof +orc +profile +xray"
# sanitizer targets, keep in sync with config-ix.cmake
@@ -36,7 +34,7 @@ CLANG_SLOT=${SLOT%%.*}
# llvm-6 for new lit options
DEPEND="
>=sys-devel/llvm-6
- virtual/libcrypt[${MULTILIB_USEDEP}]"
+ virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]"
BDEPEND="
>=dev-util/cmake-3.16
clang? ( sys-devel/clang )