summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-22 01:39:08 +0100
committerSam James <sam@gentoo.org>2024-09-22 01:39:08 +0100
commitb060b90ece8a86ae4565795fac58627e4a3c0ce1 (patch)
tree6d9c118dc2d0ac0123f8c8dbee5b4d535356453d /sys-libs
parentsys-libs/compiler-rt: depend on slotted clang for USE=clang (diff)
downloadgentoo-b060b90ece8a86ae4565795fac58627e4a3c0ce1.tar.gz
gentoo-b060b90ece8a86ae4565795fac58627e4a3c0ce1.tar.bz2
gentoo-b060b90ece8a86ae4565795fac58627e4a3c0ce1.zip
sys-libs/compiler-rt-sanitizers: depend on matching compiler-rt too for USE=clang
Implement Arfrever's suggestion 1 from https://bugs.gentoo.org/883225#c14. I was skeptical at first before because there's bigger issues when using Clang as the system compiler, especially if using libcxx too, as not all of the dependencies are visible to Portage, but this matters too with USE=clang anyway, as if we're going to try build with Clang, we need to try harder for it to be usable. Not all packages will need it anyway (compiler-rt) but compiler-rt-sanitizers does, and I also don't want to bring back the circular dep issues from 063259edf4ee32738b680757ed853ddcf678e131 and 194424374ce95cc15ae1a88af6ac4d3bd2819869 again right now (hence not changing Clang itself). Bug: https://bugs.gentoo.org/883225 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-15.0.7-r1.ebuild6
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-16.0.6-r1.ebuild6
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-17.0.6-r1.ebuild6
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-18.1.8-r1.ebuild6
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.1.0-r1.ebuild6
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.1.0_rc4.ebuild6
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0.9999.ebuild6
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240830.ebuild6
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240910.ebuild6
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240917.ebuild6
10 files changed, 40 insertions, 20 deletions
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-15.0.7-r1.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-15.0.7-r1.ebuild
index 2e9fd672aa5e..afbab6009ce0 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-15.0.7-r1.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-15.0.7-r1.ebuild
@@ -39,13 +39,15 @@ DEPEND="
virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]
"
BDEPEND="
- clang? ( sys-devel/clang:${LLVM_MAJOR} )
+ clang? (
+ sys-devel/clang:${LLVM_MAJOR}
+ sys-libs/compiler-rt:${LLVM_VERSION}
+ )
elibc_glibc? ( net-libs/libtirpc )
test? (
!!<sys-apps/sandbox-2.13
$(python_gen_any_dep ">=dev-python/lit-15[\${PYTHON_USEDEP}]")
=sys-devel/clang-${LLVM_VERSION}*:${LLVM_MAJOR}
- sys-libs/compiler-rt:${LLVM_VERSION}
)
!test? (
${PYTHON_DEPS}
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-16.0.6-r1.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-16.0.6-r1.ebuild
index aa716e0565e3..4affd9601cf0 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-16.0.6-r1.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-16.0.6-r1.ebuild
@@ -39,12 +39,14 @@ DEPEND="
virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]
"
BDEPEND="
- clang? ( sys-devel/clang:${LLVM_MAJOR} )
+ clang? (
+ sys-devel/clang:${LLVM_MAJOR}
+ sys-libs/compiler-rt:${LLVM_MAJOR}
+ )
elibc_glibc? ( net-libs/libtirpc )
test? (
$(python_gen_any_dep ">=dev-python/lit-15[\${PYTHON_USEDEP}]")
=sys-devel/clang-${LLVM_VERSION}*:${LLVM_MAJOR}
- sys-libs/compiler-rt:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-17.0.6-r1.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-17.0.6-r1.ebuild
index bb8667046370..8767e5c33010 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-17.0.6-r1.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-17.0.6-r1.ebuild
@@ -39,12 +39,14 @@ DEPEND="
virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]
"
BDEPEND="
- clang? ( sys-devel/clang:${LLVM_MAJOR} )
+ clang? (
+ sys-devel/clang:${LLVM_MAJOR}
+ sys-libs/compiler-rt:${LLVM_MAJOR}
+ )
elibc_glibc? ( net-libs/libtirpc )
test? (
$(python_gen_any_dep ">=dev-python/lit-15[\${PYTHON_USEDEP}]")
=sys-devel/clang-${LLVM_VERSION}*:${LLVM_MAJOR}
- sys-libs/compiler-rt:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-18.1.8-r1.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-18.1.8-r1.ebuild
index f682310edd92..efe21bdc59fd 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-18.1.8-r1.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-18.1.8-r1.ebuild
@@ -39,12 +39,14 @@ DEPEND="
virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]
"
BDEPEND="
- clang? ( sys-devel/clang:${LLVM_MAJOR} )
+ clang? (
+ sys-devel/clang:${LLVM_MAJOR}
+ sys-libs/compiler-rt:${LLVM_MAJOR}
+ )
elibc_glibc? ( net-libs/libtirpc )
test? (
$(python_gen_any_dep ">=dev-python/lit-15[\${PYTHON_USEDEP}]")
=sys-devel/clang-${LLVM_VERSION}*:${LLVM_MAJOR}
- sys-libs/compiler-rt:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.1.0-r1.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.1.0-r1.ebuild
index 437215e75eb9..24dcc0582eda 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.1.0-r1.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.1.0-r1.ebuild
@@ -39,12 +39,14 @@ DEPEND="
virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]
"
BDEPEND="
- clang? ( sys-devel/clang:${LLVM_MAJOR} )
+ clang? (
+ sys-devel/clang:${LLVM_MAJOR}
+ sys-libs/compiler-rt:${LLVM_MAJOR}
+ )
elibc_glibc? ( net-libs/libtirpc )
test? (
$(python_gen_any_dep ">=dev-python/lit-15[\${PYTHON_USEDEP}]")
=sys-devel/clang-${LLVM_VERSION}*:${LLVM_MAJOR}
- sys-libs/compiler-rt:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.1.0_rc4.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.1.0_rc4.ebuild
index a0198f554b14..2bee49029be5 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.1.0_rc4.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.1.0_rc4.ebuild
@@ -38,12 +38,14 @@ DEPEND="
virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]
"
BDEPEND="
- clang? ( sys-devel/clang:${LLVM_MAJOR} )
+ clang? (
+ sys-devel/clang:${LLVM_MAJOR}
+ sys-libs/compiler-rt:${LLVM_MAJOR}
+ )
elibc_glibc? ( net-libs/libtirpc )
test? (
$(python_gen_any_dep ">=dev-python/lit-15[\${PYTHON_USEDEP}]")
=sys-devel/clang-${LLVM_VERSION}*:${LLVM_MAJOR}
- sys-libs/compiler-rt:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0.9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0.9999.ebuild
index bbe6625a0707..59a64398c9bc 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0.9999.ebuild
@@ -38,12 +38,14 @@ DEPEND="
virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]
"
BDEPEND="
- clang? ( sys-devel/clang:${LLVM_MAJOR} )
+ clang? (
+ sys-devel/clang:${LLVM_MAJOR}
+ sys-libs/compiler-rt:${LLVM_MAJOR}
+ )
elibc_glibc? ( net-libs/libtirpc )
test? (
$(python_gen_any_dep ">=dev-python/lit-15[\${PYTHON_USEDEP}]")
=sys-devel/clang-${LLVM_VERSION}*:${LLVM_MAJOR}
- sys-libs/compiler-rt:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240830.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240830.ebuild
index bbe6625a0707..59a64398c9bc 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240830.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240830.ebuild
@@ -38,12 +38,14 @@ DEPEND="
virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]
"
BDEPEND="
- clang? ( sys-devel/clang:${LLVM_MAJOR} )
+ clang? (
+ sys-devel/clang:${LLVM_MAJOR}
+ sys-libs/compiler-rt:${LLVM_MAJOR}
+ )
elibc_glibc? ( net-libs/libtirpc )
test? (
$(python_gen_any_dep ">=dev-python/lit-15[\${PYTHON_USEDEP}]")
=sys-devel/clang-${LLVM_VERSION}*:${LLVM_MAJOR}
- sys-libs/compiler-rt:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240910.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240910.ebuild
index bbe6625a0707..59a64398c9bc 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240910.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240910.ebuild
@@ -38,12 +38,14 @@ DEPEND="
virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]
"
BDEPEND="
- clang? ( sys-devel/clang:${LLVM_MAJOR} )
+ clang? (
+ sys-devel/clang:${LLVM_MAJOR}
+ sys-libs/compiler-rt:${LLVM_MAJOR}
+ )
elibc_glibc? ( net-libs/libtirpc )
test? (
$(python_gen_any_dep ">=dev-python/lit-15[\${PYTHON_USEDEP}]")
=sys-devel/clang-${LLVM_VERSION}*:${LLVM_MAJOR}
- sys-libs/compiler-rt:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240917.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240917.ebuild
index bbe6625a0707..59a64398c9bc 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240917.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-20.0.0_pre20240917.ebuild
@@ -38,12 +38,14 @@ DEPEND="
virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]
"
BDEPEND="
- clang? ( sys-devel/clang:${LLVM_MAJOR} )
+ clang? (
+ sys-devel/clang:${LLVM_MAJOR}
+ sys-libs/compiler-rt:${LLVM_MAJOR}
+ )
elibc_glibc? ( net-libs/libtirpc )
test? (
$(python_gen_any_dep ">=dev-python/lit-15[\${PYTHON_USEDEP}]")
=sys-devel/clang-${LLVM_VERSION}*:${LLVM_MAJOR}
- sys-libs/compiler-rt:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}