summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-09-04 20:01:56 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-09-24 10:01:15 +0300
commit19461e2c7582c91a942bbf65cfba113d1259f35c (patch)
treedbcc4528964cb13bf09d307b857ae665f6aa2cd6 /sys-power
parentnet-voip/umurmur: remove live ebuild (diff)
downloadgentoo-19461e2c7582c91a942bbf65cfba113d1259f35c.tar.gz
gentoo-19461e2c7582c91a942bbf65cfba113d1259f35c.tar.bz2
gentoo-19461e2c7582c91a942bbf65cfba113d1259f35c.zip
sys-power/intel-undervolt: remove live ebuild
Remove live ebuild since upstream wasn't updated for a couple of years. I think it makes no sense to keep these ebuilds, especially when the non-live ebuild is already at HEAD. Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/intel-undervolt/intel-undervolt-9999.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/sys-power/intel-undervolt/intel-undervolt-9999.ebuild b/sys-power/intel-undervolt/intel-undervolt-9999.ebuild
deleted file mode 100644
index 6390ac5c14d9..000000000000
--- a/sys-power/intel-undervolt/intel-undervolt-9999.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info systemd toolchain-funcs
-
-DESCRIPTION="Intel CPU undervolting and throttling configuration tool"
-HOMEPAGE="https://github.com/kitsunyan/intel-undervolt"
-
-if [ ${PV} == "9999" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/kitsunyan/${PN}.git"
-else
- SRC_URI="https://github.com/kitsunyan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="-* ~amd64"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="elogind"
-
-DEPEND="elogind? ( sys-auth/elogind )"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="virtual/pkgconfig"
-
-CONFIG_CHECK="~INTEL_RAPL ~X86_MSR"
-
-src_configure() {
- local myconf=(
- # it's a non-standard build system
- $(usex elogind --enable-elogind '')
- $(usex elogind --eloginddir="${EPREFIX}/$(get_libdir)/elogind" '')
- --enable-openrc
- --enable-systemd
- --unitdir="$(systemd_get_systemunitdir)"
- )
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- tc-export CC
-
- local myemakeargs=(
- CC="${CC}"
- CFLAGS="${CFLAGS}"
- )
-
- emake "${myemakeargs[@]}"
-}
-
-pkg_postinst() {
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.6 ]] ; then
- elog "openrc service has been renamed to intel-undervolt-loop"
- elog "please update your startup configuration"
- fi
- done
-}