summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2022-12-15 17:55:30 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-12-23 10:32:55 +0100
commita1929d81e2d786aa1fd9d1c6382b1908f24e6694 (patch)
treefbb8095d414673728febf931956146190d9e3d70 /sys-process/btop/files/btop-1.2.13-verbose-mkdir.patch
parentapp-misc/broot: add 1.18.0 (diff)
downloadgentoo-a1929d81e2d786aa1fd9d1c6382b1908f24e6694.tar.gz
gentoo-a1929d81e2d786aa1fd9d1c6382b1908f24e6694.tar.bz2
gentoo-a1929d81e2d786aa1fd9d1c6382b1908f24e6694.zip
sys-process/btop: Backport parallel build fix and verbose mkdir
The first fix resolves build problems on machines with many threads where mkdir calls might not be finished before a compiler tries to open that specific output dir. The second fix makes the calls to mkdir verbose to make debugging easier. Closes: https://bugs.gentoo.org/884005 Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-process/btop/files/btop-1.2.13-verbose-mkdir.patch')
-rw-r--r--sys-process/btop/files/btop-1.2.13-verbose-mkdir.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-process/btop/files/btop-1.2.13-verbose-mkdir.patch b/sys-process/btop/files/btop-1.2.13-verbose-mkdir.patch
new file mode 100644
index 000000000000..bf2b1b88dbde
--- /dev/null
+++ b/sys-process/btop/files/btop-1.2.13-verbose-mkdir.patch
@@ -0,0 +1,27 @@
+From c4ee41ebc0f7fabbf4717450c889292464dbeb6d Mon Sep 17 00:00:00 2001
+From: aristocratos <gnmjpl@gmail.com>
+Date: Thu, 15 Dec 2022 17:42:07 +0100
+Subject: [PATCH] Fixed: Makefile, VERBOSE flag now shows directory creation,
+ Issue #480
+
+---
+ Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/Makefile b/Makefile
+index a52929c..c746c00 100644
+--- a/Makefile
++++ b/Makefile
+@@ -200,7 +200,9 @@ help:
+
+ #? Make the Directories
+ directories:
++ @$(VERBOSE) || printf "mkdir -p $(TARGETDIR)\n"
+ @mkdir -p $(TARGETDIR)
++ @$(VERBOSE) || printf "mkdir -p $(BUILDDIR)/$(PLATFORM_DIR)\n"
+ @mkdir -p $(BUILDDIR)/$(PLATFORM_DIR)
+
+ #? Clean only Objects
+--
+2.37.4
+