summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-20 04:20:37 +0100
committerSam James <sam@gentoo.org>2022-06-20 06:03:49 +0100
commit4e3b9beabb52e2163a358da546e33b4634617fdd (patch)
treed3b128aa5e93f710a4f0d12b4107449f6e4b7fdb /sys-process/numad
parentnet-misc/rsync: Fix implicit declaration build failure (diff)
downloadgentoo-4e3b9beabb52e2163a358da546e33b4634617fdd.tar.gz
gentoo-4e3b9beabb52e2163a358da546e33b4634617fdd.tar.bz2
gentoo-4e3b9beabb52e2163a358da546e33b4634617fdd.zip
sys-process/numad: fix -Wformat-security
Closes: https://bugs.gentoo.org/520308 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/numad')
-rw-r--r--sys-process/numad/files/numad-0.5-wformat-security.patch19
-rw-r--r--sys-process/numad/numad-0.5-r4.ebuild53
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-process/numad/files/numad-0.5-wformat-security.patch b/sys-process/numad/files/numad-0.5-wformat-security.patch
new file mode 100644
index 000000000000..5c0aa2c41f18
--- /dev/null
+++ b/sys-process/numad/files/numad-0.5-wformat-security.patch
@@ -0,0 +1,19 @@
+https://src.fedoraproject.org/rpms/numad/raw/f21/f/0001-Fix-build-with-Werror-format-security.patch
+https://bugs.gentoo.org/520308
+
+From 6ab732334bc765d4b5883ddde0e9891b4813d136 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
+Date: Mon, 20 Jan 2014 22:25:58 +0200
+Subject: [PATCH 1/2] Fix build with -Werror=format-security
+
+--- a/numad.c
++++ b/numad.c
+@@ -154,7 +154,7 @@ void numad_log(int level, const char *fmt, ...) {
+ }
+ char buf[BUF_SIZE];
+ time_t ts = time(NULL);
+- sprintf(buf, ctime(&ts));
++ sprintf(buf, "%s", ctime(&ts));
+ char *p = &buf[strlen(buf) - 1];
+ *p++ = ':';
+ *p++ = ' ';
diff --git a/sys-process/numad/numad-0.5-r4.ebuild b/sys-process/numad/numad-0.5-r4.ebuild
new file mode 100644
index 000000000000..33f98562b754
--- /dev/null
+++ b/sys-process/numad/numad-0.5-r4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://pagure.io/numad.git"
+ inherit git-r3
+else
+ EGIT_COMMIT="334278ff3d774d105939743436d7378a189e8693"
+ SRC_URI="mirror://gentoo/numad-0.5-${EGIT_COMMIT:0:7}.tar.bz2"
+ KEYWORDS="~amd64 -arm ~arm64 ~ppc64 ~s390 ~x86"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT:0:7}"
+fi
+
+DESCRIPTION="The NUMA daemon that manages application locality"
+HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+CONFIG_CHECK="~NUMA ~CPUSETS"
+
+PATCHES=(
+ "${FILESDIR}/0001-Fix-man-page-directory-creation.patch"
+ "${FILESDIR}/${PN}-0.5-ldlibs.patch"
+ "${FILESDIR}/${PN}-0.5-wformat-security.patch"
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -std=gnu99"
+}
+
+src_install() {
+ emake prefix="${ED}"/usr install
+
+ newinitd "${FILESDIR}"/numad.initd numad
+ newconfd "${FILESDIR}"/numad.confd numad
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/numad.logrotated numad
+
+ insinto /etc
+ doins numad.conf
+ systemd_dounit numad.service
+}