summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-23 13:10:12 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-23 13:10:30 +0100
commit6ba0a475569468dcf6d36805833207eb75854189 (patch)
tree7c16134d1958ba48529fdd41a65fa87401b986f0 /sys-process
parentnet-misc/youtube-dl: Old. (diff)
downloadgentoo-6ba0a475569468dcf6d36805833207eb75854189.tar.gz
gentoo-6ba0a475569468dcf6d36805833207eb75854189.tar.bz2
gentoo-6ba0a475569468dcf6d36805833207eb75854189.zip
sys-process/cronie: Changed HOMEPAGE from fedorahosted to github.
This also resulted in a different source tarball for version 1.5.1 because the tarball on github does not contain any pre-processed autotools files. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/cronie/Manifest2
-rw-r--r--sys-process/cronie/cronie-1.5.1.ebuild21
2 files changed, 15 insertions, 8 deletions
diff --git a/sys-process/cronie/Manifest b/sys-process/cronie/Manifest
index 1fa47d457848..b1a3bfe39480 100644
--- a/sys-process/cronie/Manifest
+++ b/sys-process/cronie/Manifest
@@ -1,2 +1,2 @@
DIST cronie-1.5.0.tar.gz 242072 SHA256 9cf0e3f4f5042a9c09413d62c8e0c055e12401f70b112465f0f81f2c84ebfb3f SHA512 cad4d78cbb58ea32d1093890b316b6599d115b29f367eecc2e4a0a3560ab85ac85aa159886c883e46defb6212432d37f425396cfca686e4dd8526102ca4dd8fe WHIRLPOOL 69cb81b1d5673137132d921f8ed917e83965c5511004f58d386bb36e40787d30c640a3527d933346f3071b781c217b3001ee089045841ff054b965638e217744
-DIST cronie-1.5.1.tar.gz 243384 SHA256 6c73666102a6b5d35e2eaf1bd06925f2d4b0cef8d3323c37286dda3089a85338 SHA512 01cd289c459c916bc53d1b0d8a8235060d6670d8bb401e6b324757780461e0071d247e3cc98f72a845a0b4aedea79b502e8077976cb38a37e88628e31e4c23d4 WHIRLPOOL 4540d16dff83d7c30da89896df75f83c54b688e0e89eec6820a2b5e8ee734fb2f04265508306f40eddc54dad157890ed6d6c3389e10516a1159e8cf5d9ecb733
+DIST cronie-1.5.1.tar.gz 114848 SHA256 14701a1b952d3cf730ac73db626a6becd049c2d44dde43cd53e00643c573e0b6 SHA512 7e5b2e5cc782d04b84ffced21b4601ed5a041c125ec9daa3ae3c704c04b376b07f8f6e6e1351659690ce695ca4c9373456420099eefde985e15fbe5d3ebdcf5a WHIRLPOOL 9eb12a529fb5072d4b3e69a1c3d2af8c01515ff044b7f453959f992f1b60bd7ed2b7343d50e8d9ff7eca241d3a6ffcd33b8e1359747ca3c652025af18c2b409a
diff --git a/sys-process/cronie/cronie-1.5.1.ebuild b/sys-process/cronie/cronie-1.5.1.ebuild
index a70590a8a089..baf6397d15e7 100644
--- a/sys-process/cronie/cronie-1.5.1.ebuild
+++ b/sys-process/cronie/cronie-1.5.1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
-inherit cron eutils pam systemd user
+inherit autotools cron eutils pam systemd user
DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron"
-SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
-HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+HOMEPAGE="https://github.com/cronie-crond/cronie"
+SRC_URI="https://github.com/cronie-crond/cronie/archive/${P}.tar.gz"
LICENSE="ISC BSD BSD-2 GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -21,14 +21,21 @@ RDEPEND="${DEPEND}"
#cronie supports /etc/crontab
CRON_SYSTEM_CRONTAB="yes"
-pkg_setup() {
- enewgroup crontab
-}
+S="${WORKDIR}/${PN}-${P}"
PATCHES=(
"${FILESDIR}/cronie-systemd.patch"
)
+pkg_setup() {
+ enewgroup crontab
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
SPOOL_DIR="/var/spool/cron/crontabs" \
ANACRON_SPOOL_DIR="/var/spool/anacron" \