summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-09-02 12:25:59 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-09-02 12:29:07 +0200
commit73091ea1aa893bdae121a694f92c7c98ccad871f (patch)
tree9a13530840b0414c2fd6e630b5858454553a6056 /sys-process
parentdev-util/pkgconf: amd64 stable wrt bug #693110 (diff)
downloadgentoo-73091ea1aa893bdae121a694f92c7c98ccad871f.tar.gz
gentoo-73091ea1aa893bdae121a694f92c7c98ccad871f.tar.bz2
gentoo-73091ea1aa893bdae121a694f92c7c98ccad871f.zip
sys-process/numactl: Bump to version 2.0.13
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numactl/Manifest1
-rw-r--r--sys-process/numactl/numactl-2.0.13.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-process/numactl/Manifest b/sys-process/numactl/Manifest
index 38874062a67a..879976de1f4a 100644
--- a/sys-process/numactl/Manifest
+++ b/sys-process/numactl/Manifest
@@ -1,2 +1,3 @@
DIST numactl-2.0.11.tar.gz 408175 BLAKE2B 0767d555d5254e780ef50bd66215e84208e88fb37422fd86443e53ee52faef4242ff21e6028bdb92c4e1fa7815cdb23e87cd084763539dc1d560097f43bd563f SHA512 1969d7ee0ff3de0d6f1fa42ec089a17cdb3f92cb35d453b8f8b2eec49724c43787ecbd213357013a8f2500a260b0df9844d515815ca3a0376314a0eed050a0d4
DIST numactl-2.0.12.tar.gz 423020 BLAKE2B 39d33612591df805715c51280bf34b8328ba6fc49bdaf9dd3bd67e076f9d319c9622ef72766c12e319f4be27ee9ec7f5ecb054a6e8c7c3cf568a69aea624d511 SHA512 316b10f50e6eee4cee9cf191f19381ec4a61980354eec3f9fe43fef21465bee28a82adeb9c235d4877e82950ccd14c9473b79fd1e2f5a7f598ec2fac230780ff
+DIST numactl-2.0.13.tar.gz 438096 BLAKE2B f615fafdb366930c6cdee1e4ef3d1e1d5e21f8f1c09aa904c0ebfa56972a99144991c6907127ef35794ca19d711e41b54488c5bfaeca8a0149ab9697d8c1ef75 SHA512 f7b747eb8f3ded9f3661cb0fc7b65b5ed490677f881f8fe6a000baf714747515853b4e5c8781b014241180bf16e9f0bfdf2c6f758725e34b4938696ba496b72a
diff --git a/sys-process/numactl/numactl-2.0.13.ebuild b/sys-process/numactl/numactl-2.0.13.ebuild
new file mode 100644
index 000000000000..e38e4a774774
--- /dev/null
+++ b/sys-process/numactl/numactl-2.0.13.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs multilib-minimal
+
+DESCRIPTION="Utilities and libraries for NUMA systems"
+HOMEPAGE="https://github.com/numactl/numactl"
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/numactl/numactl.git"
+else
+ SRC_URI="https://github.com/numactl/numactl/releases/download/v${PV}/${P}.tar.gz"
+ # ARM lacks the __NR_migrate_pages syscall.
+ KEYWORDS="~amd64 -arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.10-numademo-cflags.patch #540856
+)
+
+src_prepare() {
+ default
+ eautoreconf
+ # We need to copy the sources or else tests will fail
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ multilib_is_native_abi && default || emake libnuma.la
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi ; then
+ if [[ -d /sys/devices/system/node ]] ; then
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ emake regress2
+ else
+ ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
+ fi
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
+ find "${ED}"/usr/ -type f -name libnuma.la -delete || die
+}
+
+multilib_src_install_all() {
+ local DOCS=( README.md )
+ einstalldocs
+ # delete man pages provided by the man-pages package #238805
+ rm -r "${ED}"/usr/share/man/man[25] || die
+}