summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-05 13:29:13 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-05 13:29:13 +0200
commit789c97e456fa86b20fd886cc1593ba067f1d93b5 (patch)
tree5959ee3bf76f3340f13f4848c629039ef9b7931b /sys-process
parentsys-apps/x86info: Respect CFLAGS (diff)
downloadgentoo-789c97e456fa86b20fd886cc1593ba067f1d93b5.tar.gz
gentoo-789c97e456fa86b20fd886cc1593ba067f1d93b5.tar.bz2
gentoo-789c97e456fa86b20fd886cc1593ba067f1d93b5.zip
sys-process/watchpid: Respect CFLAGS
Closes: https://github.com/gentoo/gentoo/pull/20606 Closes: https://bugs.gentoo.org/726054 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/watchpid/files/watchpid-0.1-cflags.patch11
-rw-r--r--sys-process/watchpid/metadata.xml8
-rw-r--r--sys-process/watchpid/watchpid-0.1-r2.ebuild25
3 files changed, 25 insertions, 19 deletions
diff --git a/sys-process/watchpid/files/watchpid-0.1-cflags.patch b/sys-process/watchpid/files/watchpid-0.1-cflags.patch
new file mode 100644
index 000000000000..c82e5607f5ab
--- /dev/null
+++ b/sys-process/watchpid/files/watchpid-0.1-cflags.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/726054
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -64,7 +64,6 @@ VERSION = @VERSION@
+
+ bin_PROGRAMS = watchpid
+ watchpid_SOURCES = watchpid.c
+-CFLAGS = -Wall -Werror -O3
+ man_MANS = watchpid.1
+ EXTRA_DIST = $(man_MANS)
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/sys-process/watchpid/metadata.xml b/sys-process/watchpid/metadata.xml
index 56c124413057..4eb20a048df2 100644
--- a/sys-process/watchpid/metadata.xml
+++ b/sys-process/watchpid/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
-</maintainer>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
</pkgmetadata>
diff --git a/sys-process/watchpid/watchpid-0.1-r2.ebuild b/sys-process/watchpid/watchpid-0.1-r2.ebuild
index 93e680eadf24..e190ab0d69d9 100644
--- a/sys-process/watchpid/watchpid-0.1-r2.ebuild
+++ b/sys-process/watchpid/watchpid-0.1-r2.ebuild
@@ -1,28 +1,23 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit multilib-minimal
+inherit multilib-minimal toolchain-funcs
DESCRIPTION="Watches a process for termination"
-SRC_URI="mirror://gentoo/${PN}_${PV}.tar.gz"
HOMEPAGE="http://www.codepark.org/"
-KEYWORDS="amd64 ppc x86"
+SRC_URI="mirror://gentoo/${PN}_${PV}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
-DOCS=( README AUTHORS )
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+)
multilib_src_configure() {
+ tc-export CC
ECONF_SOURCE="${S}" econf
}
-
-src_compile() {
- multilib-minimal_src_compile
-}
-
-src_install() {
- multilib-minimal_src_install
-}