summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-30 15:43:27 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-30 18:43:00 +0100
commit0d9eb4d33f7f3e34f4a42396684ab1e2e9a23a57 (patch)
tree2e5a68d2b2a2831c3fd936950467c292ee46c0c8 /virtual/python-enum34/python-enum34-2.ebuild
parentdev-python/flake8: Use virtual/python-enum34 (diff)
downloadgentoo-0d9eb4d33f7f3e34f4a42396684ab1e2e9a23a57.tar.gz
gentoo-0d9eb4d33f7f3e34f4a42396684ab1e2e9a23a57.tar.bz2
gentoo-0d9eb4d33f7f3e34f4a42396684ab1e2e9a23a57.zip
virtual/python-enum34: pypy3 no longer requires enum34
Bug: https://bugs.gentoo.org/682012 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'virtual/python-enum34/python-enum34-2.ebuild')
-rw-r--r--virtual/python-enum34/python-enum34-2.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/virtual/python-enum34/python-enum34-2.ebuild b/virtual/python-enum34/python-enum34-2.ebuild
new file mode 100644
index 000000000000..0d67c5d7b349
--- /dev/null
+++ b/virtual/python-enum34/python-enum34-2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for Python enum34 module"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' \
+ 'python2*' python3_3 pypy)"