summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-10-30 11:24:43 +0000
committerJoonas Niilola <juippis@gentoo.org>2024-12-04 20:10:36 +0200
commit3fbab7e6c365e1f5e9a3c46426f51a723c0ef799 (patch)
treea099916a9b02bd798aa53951ace0e41eb6e53d29 /www-apache/modsecurity-crs
parentwww-apache/modsecurity-crs: drop 3.3.5, 4.0.0 (diff)
downloadgentoo-3fbab7e6c365e1f5e9a3c46426f51a723c0ef799.tar.gz
gentoo-3fbab7e6c365e1f5e9a3c46426f51a723c0ef799.tar.bz2
gentoo-3fbab7e6c365e1f5e9a3c46426f51a723c0ef799.zip
www-apache/modsecurity-crs: add 3.3.7
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39148 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apache/modsecurity-crs')
-rw-r--r--www-apache/modsecurity-crs/Manifest1
-rw-r--r--www-apache/modsecurity-crs/modsecurity-crs-3.3.7.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/www-apache/modsecurity-crs/Manifest b/www-apache/modsecurity-crs/Manifest
index 8589fa4d6142..a481ef51e3a2 100644
--- a/www-apache/modsecurity-crs/Manifest
+++ b/www-apache/modsecurity-crs/Manifest
@@ -1,3 +1,4 @@
DIST modsecurity-crs-3.3.6.tar.gz 301489 BLAKE2B 8e7b5b3aacd37731b8d83bb6d761454ad48b625e40c8a951a7d6a4ddc9c62efd41cc9c66d74b334d9339f48aa0fe7399e61316edfea6b34b42708084512222ca SHA512 6e5a7b3ceb7d4a8500044425f7439f1967248ff8ab54c4e8d6b4592460afa75d8a7ac973766b58e54cb02cc08559e61fe8689488fc1261b54a8d49933e65bde2
+DIST modsecurity-crs-3.3.7.tar.gz 301659 BLAKE2B 8a0fadc70738971b39ee65e8e4338efadf26a7c746ae105e93616000a11d856b60bff79762841f87bab0e8c3be89ac53b4c054cc25c5d4c0564b17f55f6b67f4 SHA512 5d80b4d73da3cb58d827f43bea3eac60282ee77aa3b03d7a38e18cfd4c3f932c572765c2fb209d36a2815381cfee2318cf53837c89ffaa68411b0dee72a7b998
DIST modsecurity-crs-4.7.0.tar.gz 513616 BLAKE2B c3c25baf0ee5b0508d9c5b55702060023c94f4b794bf00f3be47b0541ca90a9fabda9d3d28a95d4b589e5ac971dfb5b9fba731711db389d2d4dcdab9944d8109 SHA512 13b652768a0ea3c3f5e1cae6bc25d520ef22943faf87564340751374e5df238b17526466cafd452846edfc436f6ad98cdd5ed5496531981c1ebebd2c179d22d7
DIST modsecurity-crs-4.8.0.tar.gz 486857 BLAKE2B 3951ffcbf44ee01fbe9199655812a448ad0a5a0b02b68f44b4c8fd83f9533edfa96449bcb90c297bd7abfa4bb236951a4b0828b75a14bc9c63033dac48cd4ca2 SHA512 07a35b58da5d614ac3858be46ca7e74dfaceafff1e034d363a31ab522bfda2b80475bf3c73e74cb10e6c7c6345129c034291240315c4dd598aa4bad49c7e82c0
diff --git a/www-apache/modsecurity-crs/modsecurity-crs-3.3.7.ebuild b/www-apache/modsecurity-crs/modsecurity-crs-3.3.7.ebuild
new file mode 100644
index 000000000000..05dc6b1c3a52
--- /dev/null
+++ b/www-apache/modsecurity-crs/modsecurity-crs-3.3.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="OWASP ModSecurity Core Rule Set"
+HOMEPAGE="https://coreruleset.org/"
+SRC_URI="https://github.com/coreruleset/coreruleset/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/coreruleset-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+apache2"
+
+RDEPEND="apache2? ( >=www-apache/mod_security-2.9.6 )"
+
+DOCS=( CHANGES.md CONTRIBUTORS.md crs-setup.conf.example KNOWN_BUGS README.md )
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r rules
+
+ einstalldocs
+
+ if use apache2; then
+ # I don't think it's worth pulling in apache-module.eclass just for
+ # this path...
+ insinto /etc/apache2/modules.d
+ doins "${FILESDIR}/80_mod_security-crs.conf"
+ fi
+}
+
+pkg_postinst() {
+ if use apache2; then
+ einfo "The CRS configuration file has been installed to:"
+ einfo " ${ROOT}/etc/apache2/modules.d/80_mod_security-crs.conf"
+ fi
+
+ optfeature "apache-less installations, e.g. nginx" dev-libs/modsecurity
+}