summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/novnc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/novnc')
-rw-r--r--www-apps/novnc/Manifest1
-rw-r--r--www-apps/novnc/files/noVNC.confd4
-rw-r--r--www-apps/novnc/files/noVNC.initd30
-rw-r--r--www-apps/novnc/metadata.xml13
-rw-r--r--www-apps/novnc/novnc-0.5.ebuild46
-rw-r--r--www-apps/novnc/novnc-9999.ebuild59
6 files changed, 153 insertions, 0 deletions
diff --git a/www-apps/novnc/Manifest b/www-apps/novnc/Manifest
new file mode 100644
index 000000000000..9ac3b73c84a1
--- /dev/null
+++ b/www-apps/novnc/Manifest
@@ -0,0 +1 @@
+DIST novnc-0.5.tar.gz 775617 SHA256 6d702a628c85384118d85d51225770a78dd62d805229f56e42b92798c87baa31 SHA512 babc8e3996a952c82794a135e71217b92d9bc77850f4da4b1664f54da03d8a40eb708a86af8bcfb97261cb843c79b91a9040e4607388d51c201f16ef24786ed6 WHIRLPOOL 614aded12ab783968b2ee3a4ff5bb54278d9bc4529139b223f3c9f2f1201493c6f450835d55b416f8b6f8b2193cc126c60bf60578aa1add82f2b341f98443d67
diff --git a/www-apps/novnc/files/noVNC.confd b/www-apps/novnc/files/noVNC.confd
new file mode 100644
index 000000000000..50ddb5cc3e57
--- /dev/null
+++ b/www-apps/novnc/files/noVNC.confd
@@ -0,0 +1,4 @@
+FLAG_FILE=/etc/nova/nova.conf
+WEB_ROOT=/opt/noVNC
+LOG_PATH=/var/log/noVNC
+CERT_FILE=/opt/noVNC/self.pem
diff --git a/www-apps/novnc/files/noVNC.initd b/www-apps/novnc/files/noVNC.initd
new file mode 100644
index 000000000000..37367c93c2d5
--- /dev/null
+++ b/www-apps/novnc/files/noVNC.initd
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+#
+# Author: Cor Cornelisse <corcornelisse@gmail.com>
+
+pidfile="/var/run/${SVCNAME}.pid"
+command="/usr/bin/nova-novncproxy"
+command_args="--flagfile=${FLAG_FILE} --cert=${CERT_FILE} --web ${WEB_ROOT}"
+command_background="yes"
+start_stop_daemon_args="--stdout ${LOG_PATH}/${SVCNAME}.log --stderr ${LOG_PATH}/${SVCNAME}.err"
+
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -r /etc/conf.d/${SVCNAME} ]; then
+ eerror "No config file found: /etc/conf.d/${SVCNAME}"
+ return 1
+ fi
+ return 0
+}
+
+
+start_pre() {
+ checkconfig || return $?
+}
diff --git a/www-apps/novnc/metadata.xml b/www-apps/novnc/metadata.xml
new file mode 100644
index 000000000000..9cf505ad0218
--- /dev/null
+++ b/www-apps/novnc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <use>
+ <flag name="nova">Installs Openstack Nova for it's libraries</flag>
+ </use>
+</pkgmetadata>
diff --git a/www-apps/novnc/novnc-0.5.ebuild b/www-apps/novnc/novnc-0.5.ebuild
new file mode 100644
index 000000000000..240136147726
--- /dev/null
+++ b/www-apps/novnc/novnc-0.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
+HOMEPAGE="http://kanaka.github.com/noVNC/"
+SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/noVNC-${PV}"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="nova"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ nova? ( dev-python/websockify
+ sys-cluster/nova
+ dev-python/matplotlib
+ dev-python/numpy )"
+
+src_prepare() {
+ # Use unbundled websockify.
+ sed 's:${HERE}/websockify:websockify:' -i utils/launch.sh || die
+}
+
+src_install() {
+ dodir /usr/share/novnc
+ insinto /usr/share/novnc
+ doins -r *.html images include
+ dodoc README.md
+ exeinto /usr/share/novnc/utils
+ doexe utils/launch.sh
+
+ if use nova; then
+ dobin utils/nova-novncproxy
+
+ newconfd "${FILESDIR}/noVNC.confd" nova-noVNC
+ newinitd "${FILESDIR}/noVNC.initd" nova-noVNC
+
+ diropts -m 0750
+ dodir /var/log/noVNC
+ fi
+}
diff --git a/www-apps/novnc/novnc-9999.ebuild b/www-apps/novnc/novnc-9999.ebuild
new file mode 100644
index 000000000000..a56c29dcc531
--- /dev/null
+++ b/www-apps/novnc/novnc-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-2
+
+DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
+HOMEPAGE="http://kanaka.github.com/noVNC/"
+EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
+S="${WORKDIR}/noVNC-${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/numpy"
+
+src_compile() {
+ cd "${S}/utils"
+ emake
+}
+
+src_install() {
+ dodir /usr/share/novnc
+ dodir /usr/share/novnc/utils
+ dodir /usr/share/novnc/include
+ dodir /usr/share/novnc/images
+
+ exeinto /usr/share/novnc/utils
+ doexe utils/json2graph.py
+ doexe utils/launch.sh
+ doexe utils/nova-novncproxy
+ doexe utils/rebind
+ doexe utils/rebind.so
+ doexe utils/u2x11
+ doexe utils/web.py
+ doexe utils/wsproxy.py
+ doexe utils/websocket.py
+
+ docinto /usr/share/novnc/docs
+ dodoc README.md
+ dodoc LICENSE.txt
+
+ dosym /usr/share/novnc/images/favicon.ico /usr/share/novnc/
+ cp -pPR "*.html" "${D}/usr/share/novnc/"
+ cp -pPR "include/*" "${D}/usr/share/novnc/include"
+ cp -pPR "images/*" "${D}/usr/share/novnc/images"
+
+ newconfd "${FILESDIR}/noVNC.confd" noVNC
+ newinitd "${FILESDIR}/noVNC.initd" noVNC
+
+ diropts -m 0750
+ dodir /var/log/noVNC
+}