summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-10-10 22:07:23 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-10-10 22:07:23 +0200
commit1e2992bef4086db539bc6dab3a46facddf228ac7 (patch)
treeaf5d7fe4636c1a71f211cf81ab10344ba4d737fe /www-apps
parentnet-ftp/pure-ftpd: update live ebuild (diff)
downloadgentoo-1e2992bef4086db539bc6dab3a46facddf228ac7.tar.gz
gentoo-1e2992bef4086db539bc6dab3a46facddf228ac7.tar.bz2
gentoo-1e2992bef4086db539bc6dab3a46facddf228ac7.zip
www-apps/phpsysinfo: add 3.4.4
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/phpsysinfo/Manifest1
-rw-r--r--www-apps/phpsysinfo/phpsysinfo-3.4.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/www-apps/phpsysinfo/Manifest b/www-apps/phpsysinfo/Manifest
index 5f3d2aeb5423..582949560b02 100644
--- a/www-apps/phpsysinfo/Manifest
+++ b/www-apps/phpsysinfo/Manifest
@@ -1 +1,2 @@
DIST phpsysinfo-3.4.3.tar.gz 1101922 BLAKE2B b4800af1bb6995f898681d80c95c87d7120146078b1a0f24d65c0217b6c6ea1d9dc9e9a8c54d9e4c1f41988ed68e28f263093af1217caf76af48b001da912136 SHA512 d0c5f0d36da6fa85dd299c8550633055fecc15e16f0f9a57e6765691a0c766da9893fd2be539492fb45b482165b1215ca9950b50f7bddfa84294833c06de27f7
+DIST phpsysinfo-3.4.4.tar.gz 1109842 BLAKE2B ef192c27e6aff9c95a05b68780287c9118d79df8e95cb04447ab82fd3334dc18b0b790a1b66c903532a259a2243145fd03f8b746502072055c5beeec32e1d36b SHA512 0f2a6be998eb624ff473a9571f4975c2da8909e2f60826b0c713d781e22cd963fd864ce7bd97992321f86b0d69efb123caeeb24603dbd2223a9986d5e6e8720c
diff --git a/www-apps/phpsysinfo/phpsysinfo-3.4.4.ebuild b/www-apps/phpsysinfo/phpsysinfo-3.4.4.ebuild
new file mode 100644
index 000000000000..1b43fbab64d0
--- /dev/null
+++ b/www-apps/phpsysinfo/phpsysinfo-3.4.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature webapp
+
+DESCRIPTION="A customizable PHP script that displays information about your system nicely"
+HOMEPAGE="https://phpsysinfo.github.io/phpsysinfo/"
+SRC_URI="https://github.com/rk4an/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+RDEPEND="
+ dev-lang/php[simplexml,xml,xsl(+),xslt(+),unicode]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md README*
+ rm CHANGELOG.md COPYING README* .gitignore || die
+
+ mv phpsysinfo.ini{.new,} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/phpsysinfo.ini
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ optfeature "showing disk temperatures." app-admin/hddtemp
+ optfeature "showing system uptime." app-misc/uptimed
+ optfeature "showing snmp statistics." net-analyzer/net-snmp
+ optfeature "showing iptables rules." net-firewall/iptables
+ optfeature "showing ipmi sensors." sys-apps/ipmitool
+ optfeature "showing ipmi sensors." sys-apps/ipmiutil
+ optfeature "showing system sensors." sys-apps/lm-sensors
+ optfeature "showing s.m.a.r.t. health." sys-apps/smartmontools
+ optfeature "showing lsi raid controller health." sys-block/megactl
+ optfeature "showing fake raid statistics." sys-fs/dmraid
+ optfeature "showing software raid statistics." sys-fs/mdadm
+ optfeature "showing quota information." sys-fs/quota
+ optfeature "showing ipmi sensors." sys-libs/freeipmi
+ optfeature "showing apc ups statistics." sys-power/apcupsd
+ optfeature "showing ups statistics." sys-power/nut
+}