summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-22 22:56:34 +0100
committerCraig Andrews <candrews@gentoo.org>2024-03-23 14:35:18 -0400
commit410641374d9b6cb2ef80128adc43731c695d19b1 (patch)
tree5ef479568bb5a207f52cdde58af3602452ca4bb6 /www-apps
parentdev-libs/libdnet: fix tests (diff)
downloadgentoo-410641374d9b6cb2ef80128adc43731c695d19b1.tar.gz
gentoo-410641374d9b6cb2ef80128adc43731c695d19b1.tar.bz2
gentoo-410641374d9b6cb2ef80128adc43731c695d19b1.zip
www-apps/sonarr-bin: move from www-apps/sonarr
Bug: https://bugs.gentoo.org/915346 Signed-off-by: Maciej Barć <xgqt@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/35869 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/sonarr-bin/Manifest (renamed from www-apps/sonarr/Manifest)0
-rw-r--r--www-apps/sonarr-bin/files/sonarr.init-r2 (renamed from www-apps/sonarr/files/sonarr.init-r2)0
-rw-r--r--www-apps/sonarr-bin/files/sonarr.logrotate (renamed from www-apps/sonarr/files/sonarr.logrotate)0
-rw-r--r--www-apps/sonarr-bin/files/sonarr.service-r1 (renamed from www-apps/sonarr/files/sonarr.service-r1)0
-rw-r--r--www-apps/sonarr-bin/metadata.xml (renamed from www-apps/sonarr/metadata.xml)0
-rw-r--r--www-apps/sonarr-bin/sonarr-bin-4.0.2.1341.ebuild74
-rw-r--r--www-apps/sonarr/sonarr-4.0.2.1341.ebuild65
7 files changed, 74 insertions, 65 deletions
diff --git a/www-apps/sonarr/Manifest b/www-apps/sonarr-bin/Manifest
index 5c3fdde8de14..5c3fdde8de14 100644
--- a/www-apps/sonarr/Manifest
+++ b/www-apps/sonarr-bin/Manifest
diff --git a/www-apps/sonarr/files/sonarr.init-r2 b/www-apps/sonarr-bin/files/sonarr.init-r2
index 76b8dbed164b..76b8dbed164b 100644
--- a/www-apps/sonarr/files/sonarr.init-r2
+++ b/www-apps/sonarr-bin/files/sonarr.init-r2
diff --git a/www-apps/sonarr/files/sonarr.logrotate b/www-apps/sonarr-bin/files/sonarr.logrotate
index 9514fa02651e..9514fa02651e 100644
--- a/www-apps/sonarr/files/sonarr.logrotate
+++ b/www-apps/sonarr-bin/files/sonarr.logrotate
diff --git a/www-apps/sonarr/files/sonarr.service-r1 b/www-apps/sonarr-bin/files/sonarr.service-r1
index 542f5d7f1031..542f5d7f1031 100644
--- a/www-apps/sonarr/files/sonarr.service-r1
+++ b/www-apps/sonarr-bin/files/sonarr.service-r1
diff --git a/www-apps/sonarr/metadata.xml b/www-apps/sonarr-bin/metadata.xml
index be137c9a13d0..be137c9a13d0 100644
--- a/www-apps/sonarr/metadata.xml
+++ b/www-apps/sonarr-bin/metadata.xml
diff --git a/www-apps/sonarr-bin/sonarr-bin-4.0.2.1341.ebuild b/www-apps/sonarr-bin/sonarr-bin-4.0.2.1341.ebuild
new file mode 100644
index 000000000000..f10489599d33
--- /dev/null
+++ b/www-apps/sonarr-bin/sonarr-bin-4.0.2.1341.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Sonarr is a Smart PVR for newsgroup and bittorrent users"
+HOMEPAGE="https://www.sonarr.tv"
+
+SRC_URI="
+ amd64? (
+ elibc_glibc? (
+ https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-x64.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-musl-x64.tar.gz
+ )
+ )
+ arm? (
+ elibc_glibc? (
+ https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-arm.tar.gz
+ )
+ )
+ arm64? (
+ elibc_glibc? (
+ https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-arm64.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-musl-arm64.tar.gz
+ )
+ )
+"
+S="${WORKDIR}/Sonarr"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist strip test"
+
+RDEPEND="
+ acct-group/sonarr
+ acct-user/sonarr
+ media-video/mediainfo
+ dev-libs/icu
+ dev-util/lttng-ust:0
+ dev-db/sqlite
+"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # https://github.com/dotnet/runtime/issues/57784
+ rm libcoreclrtraceptprovider.so Sonarr.Update/libcoreclrtraceptprovider.so || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}/sonarr.init-r2" sonarr
+
+ keepdir /var/lib/sonarr
+ fowners -R sonarr:sonarr /var/lib/sonarr
+
+ insinto /etc/logrotate.d
+ insopts -m0644 -o root -g root
+ newins "${FILESDIR}/sonarr.logrotate" sonarr
+
+ dodir "/opt/sonarr"
+ cp -R "${S}/." "${D}/opt/sonarr" || die "Install failed!"
+
+ systemd_newunit "${FILESDIR}/sonarr.service-r1" "sonarr.service"
+ systemd_newunit "${FILESDIR}/sonarr.service-r1" "sonarr@.service"
+}
diff --git a/www-apps/sonarr/sonarr-4.0.2.1341.ebuild b/www-apps/sonarr/sonarr-4.0.2.1341.ebuild
deleted file mode 100644
index 96ad64a73d0b..000000000000
--- a/www-apps/sonarr/sonarr-4.0.2.1341.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit systemd
-
-SRC_URI="
- amd64? (
- elibc_glibc? ( https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-x64.tar.gz )
- elibc_musl? ( https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-musl-x64.tar.gz )
- )
- arm? (
- elibc_glibc? ( https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-arm.tar.gz )
- )
- arm64? (
- elibc_glibc? ( https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-arm64.tar.gz )
- elibc_musl? ( https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-musl-arm64.tar.gz )
- )
-"
-
-DESCRIPTION="Sonarr is a Smart PVR for newsgroup and bittorrent users"
-HOMEPAGE="https://www.sonarr.tv"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="bindist strip test"
-
-RDEPEND="
- acct-group/sonarr
- acct-user/sonarr
- media-video/mediainfo
- dev-libs/icu
- dev-util/lttng-ust:0
- dev-db/sqlite
-"
-
-QA_PREBUILT="*"
-
-S="${WORKDIR}/Sonarr"
-
-src_prepare() {
- default
-
- # https://github.com/dotnet/runtime/issues/57784
- rm libcoreclrtraceptprovider.so Sonarr.Update/libcoreclrtraceptprovider.so || die
-}
-
-src_install() {
- newinitd "${FILESDIR}/${PN}.init-r2" ${PN}
-
- keepdir /var/lib/${PN}
- fowners -R ${PN}:${PN} /var/lib/${PN}
-
- insinto /etc/logrotate.d
- insopts -m0644 -o root -g root
- newins "${FILESDIR}/${PN}.logrotate" ${PN}
-
- dodir "/opt/${PN}"
- cp -R "${S}/." "${D}/opt/sonarr" || die "Install failed!"
-
- systemd_newunit "${FILESDIR}/${PN}.service-r1" "${PN}.service"
- systemd_newunit "${FILESDIR}/${PN}.service-r1" "${PN}@.service"
-}