summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-29 01:40:06 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-30 13:45:09 +0200
commit108645f338284b2ab1dc180edcf5697ba28c87c5 (patch)
tree8e37847ef1a3668ec23990945557f4a582043e9e /www-client/firefox/firefox-74.0-r2.ebuild
parentwww-client/firefox: fix PATH for FEATURES=ccache/distcc (diff)
downloadgentoo-108645f338284b2ab1dc180edcf5697ba28c87c5.tar.gz
gentoo-108645f338284b2ab1dc180edcf5697ba28c87c5.tar.bz2
gentoo-108645f338284b2ab1dc180edcf5697ba28c87c5.zip
www-client/firefox: update .desktop file
- Add support for application/pdf mime type - Add additional actions ("New Window", "New Private Window") - Add translations Closes: https://bugs.gentoo.org/705324 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client/firefox/firefox-74.0-r2.ebuild')
-rw-r--r--www-client/firefox/firefox-74.0-r2.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/www-client/firefox/firefox-74.0-r2.ebuild b/www-client/firefox/firefox-74.0-r2.ebuild
index bf2680e31471..f59e1224f9fe 100644
--- a/www-client/firefox/firefox-74.0-r2.ebuild
+++ b/www-client/firefox/firefox-74.0-r2.ebuild
@@ -757,17 +757,21 @@ PROFILE_EOF
done
# Install a 48x48 icon into /usr/share/pixmaps for legacy DEs
newicon "${icon_path}/default48.png" "${icon}.png"
- newmenu "${FILESDIR}/icon/${PN}.desktop" "${PN}.desktop"
- sed -i -e "s:@NAME@:${name}:" -e "s:@ICON@:${icon}:" \
- "${ED}/usr/share/applications/${PN}.desktop" || die
+ newmenu "${FILESDIR}/icon/${PN}-r1.desktop" "${PN}.desktop"
# Add StartupNotify=true bug 237317
+ local startup_notify="false"
if use startup-notification ; then
- echo "StartupNotify=true"\
- >> "${ED}/usr/share/applications/${PN}.desktop" \
- || die
+ startup_notify="true"
fi
+ sed -i \
+ -e "s:@NAME@:${name}:" \
+ -e "s:@EXEC@:firefox:" \
+ -e "s:@ICON@:${icon}:" \
+ -e "s:@STARTUP_NOTIFY@:${startup_notify}:" \
+ "${ED%/}/usr/share/applications/${PN}.desktop" || die
+
# Don't install llvm-symbolizer from sys-devel/llvm package
[[ -f "${ED%/}${MOZILLA_FIVE_HOME}/llvm-symbolizer" ]] && \
rm "${ED%/}${MOZILLA_FIVE_HOME}/llvm-symbolizer"