summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-03 23:23:27 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-02-15 11:52:30 -0600
commit1cebce95d40bfab03d5c92b06750b77d201be31c (patch)
treeb7b7e64cd9f8fb324d91e55d892fa1e25a9c99fa /www-client/pybugz
parentapp-portage/mgorny-dev-scripts: Bump to 50 (diff)
downloadgentoo-1cebce95d40bfab03d5c92b06750b77d201be31c.tar.gz
gentoo-1cebce95d40bfab03d5c92b06750b77d201be31c.tar.bz2
gentoo-1cebce95d40bfab03d5c92b06750b77d201be31c.zip
www-client/pybugz: multiple small fixes
- remove extraneous dependencies on setuptools The distutils eclass already handles this correctly. This includes using BDEPEND instead of DEPEND. Avoids a runtime dependency on setuptools, which has never been used -- in general software never uses `import setuptools` at runtime, and pybugz doesn't actually make use of pkg_resources either. - migrate to pep517 build - update EAPI 7 -> 8 Closes: https://bugs.gentoo.org/910045 Closes: https://github.com/gentoo/gentoo/pull/35177 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'www-client/pybugz')
-rw-r--r--www-client/pybugz/pybugz-0.13-r3.ebuild32
-rw-r--r--www-client/pybugz/pybugz-9999.ebuild10
2 files changed, 36 insertions, 6 deletions
diff --git a/www-client/pybugz/pybugz-0.13-r3.ebuild b/www-client/pybugz/pybugz-0.13-r3.ebuild
new file mode 100644
index 000000000000..17680b4e1e24
--- /dev/null
+++ b/www-client/pybugz/pybugz-0.13-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="readline(+),ssl(+)"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/williamh/pybugz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/williamh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
+HOMEPAGE="https://github.com/williamh/pybugz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp contrib/bash-completion bugz
+
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _pybugz
+}
diff --git a/www-client/pybugz/pybugz-9999.ebuild b/www-client/pybugz/pybugz-9999.ebuild
index 8f3124991403..17680b4e1e24 100644
--- a/www-client/pybugz/pybugz-9999.ebuild
+++ b/www-client/pybugz/pybugz-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="readline(+),ssl(+)"
@@ -11,7 +12,7 @@ if [ "${PV}" = "9999" ]; then
inherit git-r3
else
SRC_URI="https://github.com/williamh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
fi
inherit bash-completion-r1 distutils-r1
@@ -22,9 +23,6 @@ HOMEPAGE="https://github.com/williamh/pybugz"
LICENSE="GPL-2"
SLOT="0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
python_install_all() {
distutils-r1_python_install_all
newbashcomp contrib/bash-completion bugz