summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-misc/xxv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-misc/xxv')
-rw-r--r--www-misc/xxv/Manifest1
-rw-r--r--www-misc/xxv/files/xxv-1.0-logerror.patch29
-rw-r--r--www-misc/xxv/files/xxv.utf8-v5101
-rw-r--r--www-misc/xxv/files/xxvd-1.0.cfg162
-rw-r--r--www-misc/xxv/files/xxvd-logrotate27
-rw-r--r--www-misc/xxv/metadata.xml19
-rw-r--r--www-misc/xxv/xxv-1.6.1.ebuild191
7 files changed, 530 insertions, 0 deletions
diff --git a/www-misc/xxv/Manifest b/www-misc/xxv/Manifest
new file mode 100644
index 000000000000..2268bd6ca9fb
--- /dev/null
+++ b/www-misc/xxv/Manifest
@@ -0,0 +1 @@
+DIST xxv-1.6.1.tgz 992065 SHA256 14288f7fb4c16c536e0c861b4f213bc1a7bf19e036b6d37777989acaa9b82643
diff --git a/www-misc/xxv/files/xxv-1.0-logerror.patch b/www-misc/xxv/files/xxv-1.0-logerror.patch
new file mode 100644
index 000000000000..3c65bbda47e4
--- /dev/null
+++ b/www-misc/xxv/files/xxv-1.0-logerror.patch
@@ -0,0 +1,29 @@
+--- html/bloecke/tooltip.tmpl (Revision 1189)
++++ html/bloecke/tooltip.tmpl (Arbeitskopie)
+@@ -7,6 +7,6 @@
+ IF !ttp_offset;ttp_offset = 0;END %?>
+ <a href="<?% IF link;link;ELSE;"#";END %?>"<?% IF eventid %?>
+ onmouseover="ttpreq(this, '<?% escape(title) %?>
+- <?% IF subtitle.length > 0 %?>~<?% escape(subtitle) %?>
++ <?% IF subtitle && subtitle.length > 0 %?>~<?% escape(subtitle) %?>
+ <?% END %?>',<?% eventid %?>, <?% ttp_offset %?>);"
+ <?% END %?> >
+Index: html/tlist.tmpl
+===================================================================
+--- html/tlist.tmpl (Revision 1189)
++++ html/tlist.tmpl (Arbeitskopie)
+@@ -51,10 +51,10 @@
+ <?% END %?>
+ </tr>
+ <?% FOREACH zeile = data %?>
+- <?% aktiv = ( zeile.1 mod 2 );
+- vps = zeile.1 mod 8 div 4;
++ <?% aktiv= ( zeile.1 ? zeile.1 mod 2 : 0 );
++ vps= ( zeile.1 ? zeile.1 mod 8 div 4 : 0 );
+ day = date.format(zeile.9, "%A, %x", locale);
+- IF aktiv; rest = rest - zeile.last; END;
++ IF aktiv; rest = rest - zeile.13; END;
+ %?>
+ <?% IF oldDay != day %?>
+ <tr><td colspan='<?% zeile.size + 1 %?>' bgcolor='#DDDDDD'><b><?% day %?></b></td><tr>
+
diff --git a/www-misc/xxv/files/xxv.utf8-v5 b/www-misc/xxv/files/xxv.utf8-v5
new file mode 100644
index 000000000000..7ddd4332a6e6
--- /dev/null
+++ b/www-misc/xxv/files/xxv.utf8-v5
@@ -0,0 +1,101 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Id$
+
+RUNAS_USER="vdr"
+
+# Set Verbose Level 0 -> 5
+VERBOSE="1"
+
+#export LANG=de_DE.utf8
+
+depend() {
+ need vdr
+}
+
+# some fixed Path
+CONFIGFILE="/etc/xxv/xxvd.cfg"
+PIDFILE="/var/run/xxv/xxvd.pid"
+XXV_BIN="/usr/bin/xxvd"
+LOGFILE="/var/log/xxv/xxvd.log"
+
+xxv_logger() {
+ printf "\tXXV running as user: ${RUNAS_USER}\n" >> "${LOGFILE}"
+ printf "\tVerbose Level: ${VERBOSE}\n" >> "${LOGFILE}"
+ printf "\tYou can change this in xxv init script\n\n" >> "${LOGFILE}"
+}
+
+check_vdradmin() {
+
+ # Check at first, is VDR-Admin running
+ # Stopping, while running on same ports
+ if [ -n "`netstat -anp | grep vdradmin | grep 8080`" ] ; then
+ echo
+ eerror "VDR-Admin will Stop at first now"
+ eerror "vdradmin and xxv can not run on the same port"
+ echo
+ /etc/init.d/vdradmin stop
+ fi
+}
+
+xxv_kill_pid() {
+
+ # After unclear stop, xxvd.pid will not removed, fixed with next line
+ if [ ! -x /etc/init.d/root ]; then
+ if [ -e ${PIDFILE} -a ! -L /var/lib/init.d/started/xxv ]; then
+ rm ${PIDFILE}
+ killall xxvd 2> /dev/null
+ fi
+ fi
+
+}
+
+xxv_kill_initfile() {
+
+ # After unclear stop, init file in /var/lib/init.d/started/ still not removed
+
+ if [ ! -x /etc/init.d/root ]; then
+ if [ -L /var/lib/init.d/started/xxv -a ! -e ${PIDFILE} ]; then
+ rm /var/lib/init.d/started/xxv
+ /etc/init.d/xxv zap
+ killall xxvd 2> /dev/null
+ fi
+ fi
+
+}
+
+start() {
+ check_vdradmin
+ xxv_logger
+
+ ebegin "Start xxv"
+ echo
+ einfo "xxv running as user: ${RUNAS_USER}"
+ einfo "Verbose Level: ${VERBOSE}"
+
+ start-stop-daemon --nicelevel 15 --pidfile ${PIDFILE} --start -u ${RUNAS_USER} --exec ${XXV_BIN} -- \
+ -configfile=${CONFIGFILE} -verbose=${VERBOSE} -pidfile=${PIDFILE}
+ eend $?
+}
+
+
+stop() {
+
+ ebegin "Stopping xxvd"
+ start-stop-daemon --stop --quiet --pidfile ${PIDFILE}
+
+ xxv_kill_pid
+ xxv_kill_initfile
+
+ eend $?
+}
+
+#restart() {
+
+# xxv_kill_pid
+# xxv_kill_initfile
+
+# svc_stop
+# svc_start
+#}
diff --git a/www-misc/xxv/files/xxvd-1.0.cfg b/www-misc/xxv/files/xxvd-1.0.cfg
new file mode 100644
index 000000000000..b18f899ba581
--- /dev/null
+++ b/www-misc/xxv/files/xxvd-1.0.cfg
@@ -0,0 +1,162 @@
+[AUTOTIMER]
+active=y
+exclude=POS > 250
+interval=300
+
+[CHANNELS]
+empty=n
+file=/etc/vdr/channels.conf
+filterCA=0,1,2,3,4
+interval=300
+stripCH=short,long;provider
+
+[EPG]
+epgfile=/var/vdr/epg.data
+epgimages=/var/vdr/video/epgimages
+interval=300
+periods=12:00,18:00,20:20,22:00,23:00,00:00,02:00,04:00
+restart=3
+timeframe=2
+
+[GRAB]
+file=/tmp/live.jpg
+font=VeraBI.ttf
+imgfontsize=12
+imgquality=90
+imgtext=[?- i = channel.split(" ") -?][[? i.shift ?]] [? i.join(" ") ?]: [? event.Title ?]
+vpos=20
+xsize=480
+ysize=360
+
+[General]
+DSN=DBI:mysql:database=xxv;host=localhost;port=3306
+Language=de_DE
+PWD=xpix97
+USR=xpix
+initscript=/etc/init.d/xxv
+
+[HTTPD]
+Clients=1000
+HtmlRoot=html
+Port=8080
+StartPage=schema
+active=y
+
+[INTERFACE]
+Clients=5
+Port=8002
+active=y
+
+[LOGREAD]
+active=y
+rows=100
+syslog=/var/log/syslog
+tail=/usr/bin/tail
+
+[MUSIC]
+active=y
+clients=5
+coverimages=/var/cache/xxv/cover
+host=192.168.0.23
+path=/var/lib/video.00/MUSIC
+port=8100
+proxy=
+
+[NEWS::JABBER]
+active=n
+level=1
+passwd=password
+receiveUser=receiveUser@jabber.org
+user=newsxxv@jabber.org
+
+[NEWS::MAIL]
+active=n
+address=xxv@example.com
+interval=6
+level=1
+smtp=smtp.googlemail.com
+spwd=password
+susr=user
+
+[NEWS::RSS]
+active=y
+level=1
+
+[NEWS::VDR]
+active=y
+level=1
+
+[RECORDS]
+commandfile=/etc/vdr/reccmds.conf
+interval=600
+previewbinary=/usr/bin/vdr2jpeg
+previewcommand=vdr2jpeg
+previewcount=3
+previewimages=/var/cache/xxv/preview
+previewlistthumbs=n
+previewlog=/var/log/xxv/xxvd_mplayer.log
+vfat=n
+videodir=/var/vdr/video
+
+[REMOTE]
+active=y
+commands=/etc/vdr/commands.conf
+
+[REPORT]
+active=y
+host=www.dyndns.org
+interval=6
+
+[ROBOT]
+active=y
+interval=3600
+
+[STATUS]
+active=y
+dfBinary=/bin/df
+font=VeraBI.ttf
+history=1
+interval=15
+wcBinary=/usr/bin/wc
+whoBinary=/usr/bin/who
+
+[STREAM]
+host=192.168.0.23
+netvideo=\\192.168.0.23\video
+
+[SVDRP]
+VdrHost=localhost
+VdrPort=2001
+
+[TELNET]
+Clients=5
+Port=8001
+active=y
+
+[TIMERS]
+DVBCards=1
+Lifetime=50
+Priority=50
+afterminutes=5
+deactive=y
+file=/etc/vdr/timers.conf
+interval=300
+prevminutes=1
+
+[USER]
+active=y
+noAuth=192.168.0.0/24, 127.0.0.1/32
+tempimages=/var/cache/xxv/temp
+withAuth=192.168.1.0/24
+
+[VTX]
+active=y
+cache=packed
+dir=/var/cache/vdr/vtx
+vtximages=./share/vtx
+
+[WAPD]
+Clients=5
+Port=8085
+WMLRoot=/usr/share/xxv-0.91_pre1126/wml
+active=y
diff --git a/www-misc/xxv/files/xxvd-logrotate b/www-misc/xxv/files/xxvd-logrotate
new file mode 100644
index 000000000000..abd07be96f63
--- /dev/null
+++ b/www-misc/xxv/files/xxvd-logrotate
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+/var/log/xxv/xxvd.log {
+ compress
+ daily
+ dateext
+ maxage 365
+ rotate 99
+ size=+4096k
+ notifempty
+ missingok
+ copytruncate
+}
+
+/var/log/xxv/xxvd_mplayer.log {
+ compress
+ daily
+ dateext
+ maxage 365
+ rotate 99
+ size=+4096k
+ notifempty
+ missingok
+ copytruncate
+}
diff --git a/www-misc/xxv/metadata.xml b/www-misc/xxv/metadata.xml
new file mode 100644
index 000000000000..a1e5d37641f2
--- /dev/null
+++ b/www-misc/xxv/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hd_brummy@gentoo.org</email>
+ <name>Joerg Bornkessel</name>
+ </maintainer>
+ <longdescription lang="en">
+ To program and steer central service over a Browser the VDR
+ </longdescription>
+ <longdescription lang="de">
+ Zentraler Dienst um ueber einen Browser den VDR zu programmiern
+ und zu steuern.
+ </longdescription>
+ <use>
+ <flag name='themes'>Enable more themes via
+ <pkg>x11-themes/xxv-skins</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/www-misc/xxv/xxv-1.6.1.ebuild b/www-misc/xxv/xxv-1.6.1.ebuild
new file mode 100644
index 000000000000..ea5d2066fa57
--- /dev/null
+++ b/www-misc/xxv/xxv-1.6.1.ebuild
@@ -0,0 +1,191 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils versionator
+
+VERSION="718" # every bump, new version
+
+DESCRIPTION="WWW Admin for the VDR (Video Disk Recorder)"
+HOMEPAGE="http://projects.vdr-developer.org/projects/xxv"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz
+ mirror://gentoo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="-mplayer themes"
+
+RDEPEND=">=media-video/vdr-1.2.6
+ media-video/vdr2jpeg
+ media-fonts/corefonts
+ virtual/mysql
+ dev-perl/CGI
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-MIME-Base64
+ virtual/perl-Time-HiRes
+ virtual/perl-IO-Compress
+ dev-perl/Config-Tiny
+ dev-perl/DateManip
+ dev-perl/DBD-mysql
+ dev-perl/DBI
+ dev-perl/Digest-HMAC
+ dev-perl/Encode-Detect
+ dev-perl/Event
+ dev-perl/Font-TTF
+ dev-perl/GD[png,gif]
+ dev-perl/IO-Socket-INET6
+ dev-perl/JSON
+ dev-perl/JSON-XS
+ dev-perl/Linux-Inotify2
+ dev-perl/Locale-gettext
+ dev-perl/MP3-Info
+ dev-perl/Net-Amazon
+ dev-perl/Net-Telnet
+ dev-perl/Net-XMPP
+ dev-perl/Proc-ProcessTable
+ dev-perl/SOAP-Lite
+ dev-perl/TextToHTML
+ dev-perl/Template-GD
+ dev-perl/Template-Toolkit
+ dev-perl/XML-RSS
+ themes? ( >=x11-themes/${PN}-skins-1.6 )"
+
+PDEPEND="mplayer? ( media-video/mplayer )"
+
+SHAREDIR="/usr/share/${PN}"
+LIBDIR="/usr/lib/${PN}"
+
+DB_VERS="32"
+
+db_update_check() {
+
+ DB_VERS_OLD="`cat /var/db/pkg/www-misc/xxv-*/xxv-*.ebuild | grep DB_VERS | head -n 1 | cut -c10-11`"
+
+ if [ "${DB_VERS_OLD}" -lt "${DB_VERS}" ]; then
+ echo
+ elog "An update of the XXV Database is necessary !!!"
+ echo
+ elog "\tcd ${SHAREDIR}/contrib"
+ echo
+ elog "\tIt is really important to edit the create-database.sql file first"
+ elog "\tdue to UTF-8 Support changes in the MySQL DB !!!"
+ echo
+ elog "\tafter this run ./update-xxv -h for more info"
+ echo
+ else
+ echo
+ elog "If this is a new install"
+ elog "You have to create an empty DB for XXV"
+ echo
+ elog "do this by:"
+ elog "cd ${SHAREDIR}/contrib"
+ eerror "read the README"
+ elog "For UTF-8 support it is really important to"
+ elog "edit create-database.sql file first and run"
+ elog "emerge --config ${PN}"
+ elog "afterwards"
+ echo
+ elog "Set your own language in"
+ elog "${SHAREDIR}/locale"
+ echo
+ elog "The default user/password is:"
+ elog "User/Password: xxv:xxv"
+ elog "You should change it immediately!"
+ echo
+ eerror "edit /etc/xxv/xxvd.cfg !"
+ fi
+}
+
+pkg_setup() {
+
+ if ! has_version "www-misc/${PN}"; then
+ echo
+ einfo "After you install xxv the very first time you should consider to read"
+ einfo "http://www.vdr-wiki.de/wiki/index.php/Xxv (German only)"
+ echo
+ fi
+
+ db_update_check
+}
+
+src_prepare() {
+
+ sed -i "${S}"/bin/xxvd \
+ -e "s:debian:Gentoo:" \
+ -e "s:/var/log/xxvd.log:/var/log/xxv/xxvd.log:" \
+ -e "s:/var/run/xxvd.pid:/var/run/xxv/xxvd.pid:" \
+ -e "s:\$RealBin/../lib:${LIBDIR}:" \
+ -e "s:\$RealBin/../locale:${SHAREDIR}/locale:" \
+ -e "s:\$RealBin/../lib/XXV/MODULES:${LIBDIR}/XXV/MODULES:" \
+ -e "s:\$RealBin/../etc/xxvd.cfg:/etc/xxv/xxvd.cfg:" \
+ -e "s:\$RealBin/../doc:/usr/share/doc/${P}:" \
+ -e "s:HTMLDIR => \"\$RealBin/../:HTMLDIR => \"${SHAREDIR}/skins:" \
+ -e "s:\$RealBin/../share/vtx:${SHAREDIR}/vtx:" \
+ -e "s:\$Real Bin/../lib/XXV/OUTPUT:${LIBDIR}/XXV/OUTPUT:" \
+ -e "s:\$RealBin/../share/news:${SHAREDIR}/news:" \
+ -e "s:\$RealBin/../contrib:${SHAREDIR}/contrib:" \
+ -e "s:\$RealBin/../share/fonts/ttf-bitstream-vera:/usr/share/fonts/corefonts:" \
+ -e "s:\$RealBin/../share/xmltv:${SHAREDIR}/xmltv:"
+
+ sed -i "s:\$RealBin/../lib:${LIBDIR}:" ./locale/xgettext.pl
+}
+
+src_install() {
+
+ newinitd "${FILESDIR}"/xxv.utf8-v5 xxv
+
+ dobin bin/xxvd
+
+ insinto /etc/"${PN}"
+ newins "${FILESDIR}"/xxvd-1.0.cfg xxvd.cfg
+ chown vdr:vdr "${D}"/etc/"${PN}"/xxvd.cfg
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/xxvd-logrotate xxvd
+
+ diropts -m755 -ovdr -gvdr
+ keepdir /var/cache/xxv
+ keepdir /var/run/xxv
+ keepdir /var/log/xxv
+
+ insinto "${LIBDIR}"
+ doins -r "${S}"/lib/*
+
+ insinto "${SHAREDIR}"
+ doins -r "${S}"/share/{news,xmltv}
+
+ insinto "${SHAREDIR}"/locale
+ doins -r "${S}"/locale/*
+ fperms 0755 "${SHAREDIR}"/locale/xgettext.pl
+
+ insinto "${SHAREDIR}"/contrib
+ doins -r "${S}"/contrib/*
+ fperms 0755 "${SHAREDIR}"/contrib/update-xxv
+
+ insinto "${SHAREDIR}"/skins
+ doins -r "${S}"/{html,wml}
+ doins "${S}"/doc/docu.tmpl
+
+ cd "${S}"/doc
+ insinto /usr/share/doc/"${P}"
+ doins docu.tmpl CHANGELOG README
+ fowners vdr:vdr /usr/share/doc/"${P}"
+
+ doman xxvd.1
+}
+
+pkg_config() {
+
+ cd "${ROOT}"/"${SHAREDIR}"
+ cat ./contrib/create-database.sql | mysql -u root -p
+}
+
+pkg_postrm() {
+
+ einfo "Cleanup for old "${P}" files"
+ rm -r /usr/share/doc/"${P}"
+}