summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-07-20 19:43:26 -0500
committerMatt Turner <mattst88@gentoo.org>2018-07-27 16:18:45 -0700
commit9d1ec23e9cac2d3ea525f4365579651af187dfab (patch)
treec91c9007def0e35b8e7aafa850ebe21d2686ba01 /x11-drivers/xf86-input-libinput
parentx11-drivers/xf86-input-evdev: add --disable-selective-werror (diff)
downloadgentoo-9d1ec23e9cac2d3ea525f4365579651af187dfab.tar.gz
gentoo-9d1ec23e9cac2d3ea525f4365579651af187dfab.tar.bz2
gentoo-9d1ec23e9cac2d3ea525f4365579651af187dfab.zip
x11-drivers/xf86-input-libinput: add --disable-selective-werror
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'x11-drivers/xf86-input-libinput')
-rw-r--r--x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild7
-rw-r--r--x11-drivers/xf86-input-libinput/xf86-input-libinput-9999.ebuild7
2 files changed, 14 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild b/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild
index b3ca6c70ccb5..401446b857d9 100644
--- a/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild
+++ b/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild
@@ -44,6 +44,13 @@ src_prepare() {
[[ ${PV} == 9999 ]] && eautoreconf
}
+src_configure() {
+ local econfargs=(
+ --disable-selective-werror
+ )
+ econf "${econfargs[@]}"
+}
+
src_install() {
default
find "${D}" -name '*.la' -delete || die
diff --git a/x11-drivers/xf86-input-libinput/xf86-input-libinput-9999.ebuild b/x11-drivers/xf86-input-libinput/xf86-input-libinput-9999.ebuild
index b3ca6c70ccb5..401446b857d9 100644
--- a/x11-drivers/xf86-input-libinput/xf86-input-libinput-9999.ebuild
+++ b/x11-drivers/xf86-input-libinput/xf86-input-libinput-9999.ebuild
@@ -44,6 +44,13 @@ src_prepare() {
[[ ${PV} == 9999 ]] && eautoreconf
}
+src_configure() {
+ local econfargs=(
+ --disable-selective-werror
+ )
+ econf "${econfargs[@]}"
+}
+
src_install() {
default
find "${D}" -name '*.la' -delete || die