summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-04 12:06:45 -0500
committerMatt Turner <mattst88@gentoo.org>2024-03-04 12:07:12 -0500
commit9662525ed260e60568b1d0eb52e482aa8bf01df2 (patch)
treea22ff41bbcbefb60ac57e9520dfcd9f5f7c0b41f /x11-drivers
parentdev-lang/php: some more implicit function decl fixes for 8.1.x (diff)
downloadgentoo-9662525ed260e60568b1d0eb52e482aa8bf01df2.tar.gz
gentoo-9662525ed260e60568b1d0eb52e482aa8bf01df2.tar.bz2
gentoo-9662525ed260e60568b1d0eb52e482aa8bf01df2.zip
x11-drivers/xf86-input-wacom: Version bump to 1.2.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest1
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index 14116aae65da..072015325a84 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -1 +1,2 @@
DIST xf86-input-wacom-1.2.0.tar.bz2 647874 BLAKE2B c59e605bacb2694c2e322faba9b030112ffb57f916c816cbcb9a946fa063713c0590e1ea29273f73a84f4360b5bc5241c9768d7e61d77dfc9fb0af72b1a6f1cc SHA512 34817b87318d1fcf885e6427436a54d748a1c910026e6af0a22fafb461b227ca566cf06846f1f57c0d66412d5a3b20c95f014a71f8ef394ea8ca360a5f902318
+DIST xf86-input-wacom-1.2.1.tar.bz2 655198 BLAKE2B 0597b9c4e05ddd696943e1a03eaf1543db78ba895d8ac3d29cf6fe0a185236eb522a8511a2757c5eb965e35283e2bd4c08e4416548de1f76456d0d27575f5eaa SHA512 b8fd8496bf297ac0e44f36e8d84131600b689e27f35368895795302d4fd60d83ae9da9773c71007cf4f2b1c02d1aec27280d789821f17c57ec47b988c4f4c3bb
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.1.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.1.ebuild
new file mode 100644
index 000000000000..d0c9b40ae40e
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd udev xorg-3 meson
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="https://linuxwacom.github.io/"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libwacom-2:=
+ >=x11-base/xorg-server-1.13:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama
+ virtual/libudev:="
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 3 17; then
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ else
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present HID_WACOM; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " HID support --->"
+ ewarn " Special HID drivers --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ xorg-3_flags_setup
+
+ local emesonargs=(
+ -Dsystemd-unit-dir="$(systemd_get_systemunitdir)"
+ -Dudev-rules-dir="$(get_udevdir)/rules.d"
+ $(meson_feature test unittests)
+ -Dwacom-gobject=disabled
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}