summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libqxt/libqxt-0.6.2-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libqxt/libqxt-0.6.2-r2.ebuild')
-rw-r--r--x11-libs/libqxt/libqxt-0.6.2-r2.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/x11-libs/libqxt/libqxt-0.6.2-r2.ebuild b/x11-libs/libqxt/libqxt-0.6.2-r2.ebuild
new file mode 100644
index 000000000000..bdebee63532e
--- /dev/null
+++ b/x11-libs/libqxt/libqxt-0.6.2-r2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib qt4-r2
+
+DESCRIPTION="The Qt eXTension library provides cross-platform utility classes for the Qt toolkit"
+HOMEPAGE="http://libqxt.org/"
+SRC_URI="http://dev.libqxt.org/libqxt/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="|| ( CPL-1.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="berkdb debug doc sql web xscreensaver zeroconf"
+
+COMMON_DEPEND="
+ dev-qt/qtcore:4[ssl]
+ || (
+ ( >=dev-qt/qtgui-4.8.5:4 dev-qt/designer:4 )
+ <dev-qt/qtgui-4.8.5:4
+ )
+ x11-libs/libXrandr
+ berkdb? ( >=sys-libs/db-4.6 )
+ sql? ( dev-qt/qtsql:4 )
+ zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( dev-qt/qthelp:4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ xscreensaver? ( x11-libs/libXScrnSaver )
+"
+
+S=${WORKDIR}/${PN}-${PN}-v${PV}
+
+DOCS=( AUTHORS CHANGES README )
+PATCHES=(
+ "${FILESDIR}/${PN}-use-system-qdoc3.patch"
+ "${FILESDIR}/${PN}-invoke-prev-filter.patch" # bug 494448
+ "${FILESDIR}/${PN}-media-keys.patch" # bug 495984
+ "${FILESDIR}/${PN}-xrandr-missing-lib.patch"
+)
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ # remove insecure runpath
+ sed -i -e '/^QMAKE_RPATHDIR /d' src/qxtlibs.pri || die
+}
+
+src_configure() {
+ # custom configure script
+ local myconf=(
+ ./configure -verbose
+ -prefix "${EPREFIX}/usr"
+ -libdir "${EPREFIX}/usr/$(get_libdir)"
+ -docdir "${EPREFIX}/usr/share/doc/${PF}"
+ -qmake-bin "${EPREFIX}/usr/bin/qmake"
+ $(use debug && echo -debug || echo -release)
+ $(use berkdb || echo -no-db -nomake berkeley)
+ $(use doc || echo -nomake docs)
+ $(use sql || echo -nomake sql)
+ $(use web || echo -nomake web)
+ $(use zeroconf || echo -no-zeroconf -nomake zeroconf)
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die "./configure failed"
+
+ eqmake4 -recursive
+}
+
+src_compile() {
+ qt4-r2_src_compile
+
+ use doc && emake docs
+}
+
+pkg_postinst() {
+ if use doc; then
+ einfo
+ einfo "In case you want to browse ${PN} documentation using"
+ einfo "Qt Assistant, perform the following steps:"
+ einfo " 1. Open the Assistant"
+ einfo " 2. Edit -> Preferences -> Documentation -> Add"
+ einfo " 3. Add this path: ${EPREFIX}/usr/share/doc/${PF}/qxt.qch"
+ einfo
+ fi
+}