summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-10-19 10:52:55 -0700
committerMatt Turner <mattst88@gentoo.org>2018-10-19 10:53:11 -0700
commit714d9299e3bb74fee6be055101b3287f0ba2bd0a (patch)
tree4e25035f7fbd4396b8601078f090667b7c2a5131 /x11-libs/libxcb
parentx11-libs/libxcb: Add Python 3.7 support (diff)
downloadgentoo-714d9299e3bb74fee6be055101b3287f0ba2bd0a.tar.gz
gentoo-714d9299e3bb74fee6be055101b3287f0ba2bd0a.tar.bz2
gentoo-714d9299e3bb74fee6be055101b3287f0ba2bd0a.zip
x11-libs/libxcb: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libxcb')
-rw-r--r--x11-libs/libxcb/Manifest1
-rw-r--r--x11-libs/libxcb/libxcb-1.13.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/x11-libs/libxcb/Manifest b/x11-libs/libxcb/Manifest
index 8ef1b582c75d..8e383a3b0300 100644
--- a/x11-libs/libxcb/Manifest
+++ b/x11-libs/libxcb/Manifest
@@ -1,2 +1 @@
DIST libxcb-1.13.1.tar.bz2 506778 BLAKE2B eca685a21d40f664b611c0c8da845e3464126b101320a86db27ee4d87b85ac0ad1a41950281b7f0ecca06883c591571d059a913591b0281890b339f279b7af93 SHA512 763edff9572623674f75a858adc57b5c09591f508cc5d5093218e7bb047abdbe0a0108bd465419a8bf15c7dcdc85efdd2d4d9fd56605c41475d15dc992640c23
-DIST libxcb-1.13.tar.bz2 510453 BLAKE2B 2bdae7610cb8b3fdefeded6cf457e1c397666d235114439caba114b9e7a6b2af50f2cd8363ebaa3ddfa5c5040b8cdf2960150e1f4db141c572e12b1a2fb0ca9a SHA512 d99bbe386a65f60fcc0cc2935e4a365bc0577b5e90433e18778a665a5aee8ebc8e9e8cb0aedac0ac4a276147c0507e759a716874ea4f80792b2fc18eefbc128c
diff --git a/x11-libs/libxcb/libxcb-1.13.ebuild b/x11-libs/libxcb/libxcb-1.13.ebuild
deleted file mode 100644
index 102ff1507d80..000000000000
--- a/x11-libs/libxcb/libxcb-1.13.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-PYTHON_REQ_USE=xml
-
-XORG_DOC=doc
-XORG_MULTILIB=yes
-inherit python-any-r1 xorg-2
-
-DESCRIPTION="X C-language Bindings library"
-HOMEPAGE="https://xcb.freedesktop.org/"
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/xcb/libxcb.git"
-[[ ${PV} != 9999* ]] && \
- SRC_URI="https://xcb.freedesktop.org/dist/${P}.tar.bz2"
-
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc selinux test xkb"
-SLOT="0/1.12"
-
-RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1[${MULTILIB_USEDEP}]
- >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
- >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]"
-# Note: ${PYTHON_USEDEP} needs to go verbatim
-DEPEND="${RDEPEND}
- test? ( dev-libs/check[${MULTILIB_USEDEP}] )
- doc? ( app-doc/doxygen[dot] )
- dev-libs/libxslt
- ${PYTHON_DEPS}
- $(python_gen_any_dep \
- ">=x11-base/xcb-proto-1.13[${MULTILIB_USEDEP},\${PYTHON_USEDEP}]")"
-
-python_check_deps() {
- has_version --host-root ">=x11-base/xcb-proto-1.13[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable doc devel-docs)
- $(use_enable selinux)
- $(use_enable xkb)
- --enable-xinput
- )
- xorg-2_src_configure
-}