summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-02-27 23:14:10 -0800
committerMatt Turner <mattst88@gentoo.org>2019-02-27 23:14:16 -0800
commit8f4ae4debf9fcd3e3e9c3fb86909931661388165 (patch)
tree5df20fcb2c7c97c28c3bee38d0bc7ea91cb726a9 /x11-libs/libxkbcommon/libxkbcommon-0.8.4.ebuild
parentx11-libs/libfontenc: Version bump to 1.1.4 (diff)
downloadgentoo-8f4ae4debf9fcd3e3e9c3fb86909931661388165.tar.gz
gentoo-8f4ae4debf9fcd3e3e9c3fb86909931661388165.tar.bz2
gentoo-8f4ae4debf9fcd3e3e9c3fb86909931661388165.zip
x11-libs/libxkbcommon: Version bump to 0.8.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libxkbcommon/libxkbcommon-0.8.4.ebuild')
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.8.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.8.4.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.8.4.ebuild
new file mode 100644
index 000000000000..b5f670fbec00
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.8.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-3 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+HOMEPAGE="https://xkbcommon.org/"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+IUSE="X doc test"
+
+BDEPEND="
+ sys-devel/bison
+ X? ( x11-base/xorg-proto )
+ doc? ( app-doc/doxygen )"
+DEPEND="X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+}