summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-10-14 08:39:32 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-10-14 08:44:56 -0400
commit91c97a5dae6ab5ca1fead8aacba2c5e058f38212 (patch)
tree8e5bffb05ef793cc3292c75f44f82af04d10703f /x11-libs
parentwww-plugins/adobe-flash: Old. (diff)
downloadgentoo-91c97a5dae6ab5ca1fead8aacba2c5e058f38212.tar.gz
gentoo-91c97a5dae6ab5ca1fead8aacba2c5e058f38212.tar.bz2
gentoo-91c97a5dae6ab5ca1fead8aacba2c5e058f38212.zip
x11-libs/gdk-pixbuf: run glibc-specific test only on glibc
Gentoo-Bug: 563052 Reported-by: Anthony Basile
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.32.1-lowmem-test-glibc.patch60
-rw-r--r--x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.1.ebuild4
2 files changed, 63 insertions, 1 deletions
diff --git a/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.32.1-lowmem-test-glibc.patch b/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.32.1-lowmem-test-glibc.patch
new file mode 100644
index 000000000000..3915dff91986
--- /dev/null
+++ b/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.32.1-lowmem-test-glibc.patch
@@ -0,0 +1,60 @@
+From e1fd25a3d0c18bd941f685bbdf5aa3812403a48e Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 6 Oct 2015 09:11:38 +0200
+Subject: [PATCH] Run only pixbuf-lowmem test on GNU libc
+
+The test case depends on GNU libc specific internals so we only run it
+on GNU libc.
+
+This fixes build on Linux with musl libc.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=756078
+---
+ tests/Makefile.am | 5 -----
+ tests/pixbuf-lowmem.c | 8 ++++++++
+ 2 files changed, 8 insertions(+), 5 deletions(-)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 1f09711..2a0325a 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -19,13 +19,8 @@ LDADD = \
+ noinst_PROGRAMS += \
+ pixbuf-read \
+ pixbuf-random \
+- $(NULL)
+-
+-if OS_LINUX
+-noinst_PROGRAMS += \
+ pixbuf-lowmem \
+ $(NULL)
+-endif
+
+ test_programs = \
+ animation \
+diff --git a/tests/pixbuf-lowmem.c b/tests/pixbuf-lowmem.c
+index ae71788..9e9571f 100644
+--- a/tests/pixbuf-lowmem.c
++++ b/tests/pixbuf-lowmem.c
+@@ -24,6 +24,7 @@
+ #include <time.h>
+ #include <string.h>
+
++#ifdef __GLIBC__
+ #define PRETEND_MEM_SIZE (16 * 1024 * 1024)
+ #define REMAINING_MEM_SIZE 100000
+
+@@ -225,3 +226,10 @@ main (int argc, char **argv)
+
+ return 0;
+ }
++#else
++int
++main (int argc, char **argv)
++{
++ return 0;
++}
++#endif
+--
+2.6.1
+
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.1.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.1.ebuild
index 54226b316aba..978be553947d 100644
--- a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.1.ebuild
+++ b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.1.ebuild
@@ -6,7 +6,7 @@ EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit eutils flag-o-matic gnome2 multilib libtool multilib-minimal
+inherit autotools eutils flag-o-matic gnome2 multilib libtool multilib-minimal
DESCRIPTION="Image loading library for GTK+"
HOMEPAGE="http://www.gtk.org/"
@@ -49,6 +49,8 @@ MULTILIB_CHOST_TOOLS=(
src_prepare() {
# Upstream patches from 2.32.x
epatch "${FILESDIR}"/${P}-gint64-shift-overflow.patch
+ epatch "${FILESDIR}"/${P}-lowmem-test-glibc.patch #563052, needs eautoreconf
+ eautoreconf
# This will avoid polluting the pkg-config file with versioned libpng,
# which is causing problems with libpng14 -> libpng15 upgrade