summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-26 15:02:55 +0100
committerSam James <sam@gentoo.org>2023-06-26 15:03:11 +0100
commitad105d9d002da5a860de683cf6bf4b229091afbd (patch)
treee94385a60f551ed47a2a36be04c67571ebcc511e /x11-libs
parentwww-apps/radarr: drop 4.6.2.7490 (diff)
downloadgentoo-ad105d9d002da5a860de683cf6bf4b229091afbd.tar.gz
gentoo-ad105d9d002da5a860de683cf6bf4b229091afbd.tar.bz2
gentoo-ad105d9d002da5a860de683cf6bf4b229091afbd.zip
x11-libs/wxGTK: fix modern C issue in configure
Closes: https://bugs.gentoo.org/874441 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/wxGTK/files/wxGTK-3.0.5.1-configure-modern-c.patch54
-rw-r--r--x11-libs/wxGTK/wxGTK-3.0.5.1-r1.ebuild5
2 files changed, 57 insertions, 2 deletions
diff --git a/x11-libs/wxGTK/files/wxGTK-3.0.5.1-configure-modern-c.patch b/x11-libs/wxGTK/files/wxGTK-3.0.5.1-configure-modern-c.patch
new file mode 100644
index 000000000000..6512c6329efb
--- /dev/null
+++ b/x11-libs/wxGTK/files/wxGTK-3.0.5.1-configure-modern-c.patch
@@ -0,0 +1,54 @@
+https://github.com/wxWidgets/wxWidgets/commit/da4b42688a6cd5444eefb91bf40183d88203ffca
+https://bugs.gentoo.org/874441
+--- a/configure
++++ b/configure
+@@ -19586,6 +19586,7 @@ else
+ /* end confdefs.h. */
+
+ #include <stdio.h>
++ #include <stdlib.h>
+
+ int main()
+ {
+@@ -22300,6 +22301,7 @@ else
+
+ #include <zlib.h>
+ #include <stdio.h>
++ #include <stdlib.h>
+
+ int main()
+ {
+@@ -22422,6 +22424,7 @@ else
+
+ #include <png.h>
+ #include <stdio.h>
++ #include <stdlib.h>
+
+ int main()
+ {
+--- a/configure.in
++++ b/configure.in
+@@ -1482,6 +1482,7 @@ case "${host}" in
+ dnl Check the gcc version macro.
+ [
+ #include <stdio.h>
++ #include <stdlib.h>
+
+ int main()
+ {
+@@ -2439,6 +2440,7 @@ if test "$wxUSE_ZLIB" != "no" ; then
+ [
+ #include <zlib.h>
+ #include <stdio.h>
++ #include <stdlib.h>
+
+ int main()
+ {
+@@ -2507,6 +2509,7 @@ if test "$wxUSE_LIBPNG" != "no" ; then
+ [
+ #include <png.h>
+ #include <stdio.h>
++ #include <stdlib.h>
+
+ int main()
+ {
diff --git a/x11-libs/wxGTK/wxGTK-3.0.5.1-r1.ebuild b/x11-libs/wxGTK/wxGTK-3.0.5.1-r1.ebuild
index 6b9d506ba157..d679c0cb319d 100644
--- a/x11-libs/wxGTK/wxGTK-3.0.5.1-r1.ebuild
+++ b/x11-libs/wxGTK/wxGTK-3.0.5.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -62,7 +62,8 @@ PATCHES=(
"${WORKDIR}"/wxGTK-3.0.5_p20210214/
"${FILESDIR}"/wxGTK-${SLOT}-translation-domain.patch
"${FILESDIR}"/wxGTK-ignore-c++-abi.patch #676878
- "${FILESDIR}/${PN}-configure-tests.patch"
+ "${FILESDIR}"/${PN}-configure-tests.patch
+ "${FILESDIR}"/${PN}-3.0.5.1-configure-modern-c.patch
)
src_prepare() {