summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-15 08:24:07 +0100
committerSam James <sam@gentoo.org>2022-07-15 08:26:10 +0100
commit562fdeff2b2d760d3de02918e0e7f9f9ea4b193e (patch)
treeb341c29dfca6969eb781153a2d60272a5bfe9bca /x11-misc/idesk/files
parentdev-libs/botan: x86 stable wrt bug #858119 (diff)
downloadgentoo-562fdeff2b2d760d3de02918e0e7f9f9ea4b193e.tar.gz
gentoo-562fdeff2b2d760d3de02918e0e7f9f9ea4b193e.tar.bz2
gentoo-562fdeff2b2d760d3de02918e0e7f9f9ea4b193e.zip
x11-misc/idesk: fix build w/ newer imlib2
Closes: https://bugs.gentoo.org/827478 Closes: https://bugs.gentoo.org/828962 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/idesk/files')
-rw-r--r--x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch b/x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch
new file mode 100644
index 000000000000..36e088972543
--- /dev/null
+++ b/x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch
@@ -0,0 +1,38 @@
+https://github.com/antonialoytorrens/idesk/pull/1
+
+From b13626bbe2669b8a267ad53df93f1060379a462e Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 15 Jul 2022 08:22:12 +0100
+Subject: [PATCH] build: use pkg-config to find imlib2
+
+imlib2 1.7.5+ drops imlib2-config, hence pkg-config
+must now be used to find it.
+
+Bug: https://bugs.gentoo.org/828962
+--- a/configure.in
++++ b/configure.in
+@@ -94,19 +94,10 @@ LIBS="$LIBS $Xext_lib"
+
+ dnl Imlib2 detection
+
+-AC_PATH_GENERIC(imlib2, , [
+- AC_SUBST(IMLIB_LIBS)
+- AC_SUBST(IMLIB_CXXFLAGS) ],
+- AC_MSG_ERROR(Cannot find imlib2: Is imlib2-config in the path?
+- You need Imlib2 to build Idesk. Verify that you have Imlib2-dev))
+-
+-dnl the above doesn't work for some reason :/
+-IMLIB_LIBS=`imlib2-config --libs`
+-IMLIB_CFLAGS=`imlib2-config --cflags`
+-AC_SUBST(IMLIB_LIBS)
+-AC_SUBST(IMLIB_CXXFLAGS)
+-
+-CXXFLAGS="$CXXFLAGS $IMLIB_CXXFLAGS"
++PKG_PROG_PKG_CONFIG
++PKG_CHECK_MODULES([IMLIB], [imlib2 > 1.0])
++
++CXXFLAGS="$CXXFLAGS $IMLIB_CFLAGS"
+ LIBS="$LIBS $IMLIB_LIBS"
+
+
+