summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2025-01-02 15:31:20 +0100
committerFlorian Schmaus <flow@gentoo.org>2025-01-02 15:34:54 +0100
commitade897133caccf78962682aa9e48f7a10002c55d (patch)
tree0b43e6c1b63354d356d06d59d4056be560082903 /x11-misc/rofi
parentsys-libs/newlib: add 4.5.0.20241231 (diff)
downloadgentoo-ade897133caccf78962682aa9e48f7a10002c55d.tar.gz
gentoo-ade897133caccf78962682aa9e48f7a10002c55d.tar.bz2
gentoo-ade897133caccf78962682aa9e48f7a10002c55d.zip
x11-misc/rofi: add 1.7.6, switch to meson
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc/rofi')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.7.6.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index 75d274fd3f64..713f330e8fd6 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1 +1,2 @@
DIST rofi-1.7.5.tar.xz 772952 BLAKE2B 54511f4f793f3ba0b58294daa1d2974228904a637d13d729b0b7d974c0ebf8d0d98514705212bd42500fe90b0685a3515dc67793baa95baefe6dfc0ecdee83c7 SHA512 84cbb8ccef14fdb5d68062b17245fbcb0e9bab46534eb6c7ce532750b86fb33ce6e43ed24cf3c65e553d15b23a201c9168d97d257da4dddeddb0a7c44dd59cc0
+DIST rofi-1.7.6.tar.xz 812496 BLAKE2B 18728bde962a1082927c87c19e00356206632430975f8718f2d961966047026a2cb1266ed868f4510fbe127e7f3e3cae1308a9da69fe46609f78dbc0e8394d2f SHA512 9e2d39abd3dbd7703646e6c0f16383da8f1ec26b911817f574f388cd019c9440fca26100d2de14883c30e74f6c1c451722777dbeee1d2551fc64d78d60fa3023
diff --git a/x11-misc/rofi/rofi-1.7.6.ebuild b/x11-misc/rofi/rofi-1.7.6.ebuild
new file mode 100644
index 000000000000..d1d57fe871c1
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.7.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs xdg-utils
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/davatorium/rofi"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/davatorium/rofi"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+drun test +windowmode"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ sys-devel/bison
+ >=sys-devel/flex-2.5.39
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=dev-libs/glib-2.72:2
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libxcb:=
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-wm
+ x11-misc/xkeyboard-config
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ test? ( >=dev-libs/check-0.11 )
+"
+
+src_configure() {
+ # Doesn't work with reflex, bug #887049
+ export LEX=flex
+
+ # Requires bison, see https://bugs.gentoo.org/894634.
+ unset YACC
+
+ tc-export CC
+
+ local emesonargs=(
+ $(meson_use drun)
+ $(meson_use windowmode window)
+ $(meson_feature test check)
+ -Dimdkit=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}